summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-03 22:55:36 -0500
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-03 22:55:36 -0500
commit6d0a4d03705b96b252a6b29d3b8c188b9c903b89 (patch)
treeb8ea3f7459ae4c9b22a976259e637cc7a3d695c7 /Cargo.toml
parentc459b5e85ef9b695b3c9a107b7cf7f08847c608f (diff)
Refactor importer to store tasks in postgresql
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a89bd57..d68ab83 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,7 @@ reqwest = { version = "0.10.1", features = ["blocking", "json"] }
clap = "2"
rocket = "0.4.2"
rocket_contrib = { version = "0.4.2", default-features = false, features = ["handlebars_templates", "diesel_postgres_pool"] }
-diesel = { version = "1.0.0", features = ["postgres", "chrono"] }
+diesel = { version = "1.0.0", features = ["postgres", "chrono", "extras"] }
dotenv = "0.9.0"
bcrypt = "0.6"
base64 = "0.11"
@@ -19,4 +19,6 @@ rand = "0.7"
chrono = { version = "0.4", features = ["serde"] }
log = "0.4"
fern = { version = "0.5", features = ["colored"] }
-threadpool = "1.7" \ No newline at end of file
+threadpool = "1.7"
+timer = "0.2"
+time = "0.1" \ No newline at end of file