summaryrefslogtreecommitdiff
path: root/pnotify/pnotify-0.2/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'pnotify/pnotify-0.2/configure.in')
-rw-r--r--pnotify/pnotify-0.2/configure.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/pnotify/pnotify-0.2/configure.in b/pnotify/pnotify-0.2/configure.in
new file mode 100644
index 0000000..32be29d
--- /dev/null
+++ b/pnotify/pnotify-0.2/configure.in
@@ -0,0 +1,30 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT([pnotify],[0.2],[devel@heily.com])
+AM_INIT_AUTOMAKE(pnotify, 0.2)
+AC_CONFIG_SRCDIR([pnotify.c])
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h limits.h stdint.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_C_INLINE
+
+# Checks for library functions.
+AC_CHECK_FUNCS([atexit memset kqueue inotify])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT