summaryrefslogtreecommitdiff
path: root/nixos/aji.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2016-07-14 20:20:05 -0400
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2016-07-14 20:23:19 -0400
commit5e51bed2e787ded903be61ad1227dca208f80e6b (patch)
treed7c2839f6d2c8a0d0957b5da8e985ec965a9c942 /nixos/aji.nix
parent418be345d29bc8ae40900b9ec652be36ae0091cf (diff)
Refactor nix config.
Diffstat (limited to 'nixos/aji.nix')
-rw-r--r--nixos/aji.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/nixos/aji.nix b/nixos/aji.nix
new file mode 100644
index 0000000..abda9f8
--- /dev/null
+++ b/nixos/aji.nix
@@ -0,0 +1,49 @@
+{ config, pkgs, hardware, ... }:
+
+{
+ imports = [
+ ./configuration.nix
+ ];
+
+ # Use the gummiboot efi boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.timeout = 0;
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.initrd.luks.devices = [
+ {
+ device = "/dev/sda2";
+ name = "crypt";
+ preLVM = true;
+ allowDiscards = true;
+ }
+ ];
+ boot.kernelModules = ["tp_smapi" "thinkpad_acpi" "fbcon" "i915"];
+ boot.kernelParams = ["quiet" "acpi_osi=\"!Windows 2012\""];
+ boot.extraModulePackages = [config.boot.kernelPackages.tp_smapi];
+ boot.extraModprobeConfig = ''
+ options i915 enable_rc6=1
+ '';
+
+ networking.hostName = "aji";
+
+ fileSystems."/" = {
+ mountPoint = "/";
+ device = "/dev/mapper/cryptvg-root";
+ fsType = "btrfs";
+ options = ["subvol=aji-root" "discard" "compress=lzo"];
+ };
+ swapDevices =
+ [ { device = "/dev/mapper/cryptvg-swap"; }
+ ];
+
+ services.tlp.enable = true;
+ services.tlp.extraConfig = ''
+ # Needed for either SSD or btrfs.
+ SATA_LINKPWR_ON_BAT=max_performance
+ '';
+
+ services.xserver.xkbModel = "thinkpad60";
+
+ # The NixOS release to be compatible with for stateful data such as databases.
+ system.stateVersion = "16.03";
+}