summaryrefslogtreecommitdiff
path: root/rust/opengl/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'rust/opengl/default.nix')
-rw-r--r--rust/opengl/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/rust/opengl/default.nix b/rust/opengl/default.nix
new file mode 100644
index 0000000..522e4d0
--- /dev/null
+++ b/rust/opengl/default.nix
@@ -0,0 +1,10 @@
+with import <nixpkgs> {};
+with xorg;
+{
+ allowUnfree = true;
+ games = stdenv.mkDerivation rec {
+ name = "opengl";
+ buildInputs = [ libXi libX11 xorg.libXext xorg.libXcursor xorg.libXrandr xorg.libXxf86vm mesa openal ];
+ LD_LIBRARY_PATH = lib.makeLibraryPath buildInputs;
+ };
+}