summaryrefslogtreecommitdiff
path: root/rust/controller/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'rust/controller/flake.nix')
-rw-r--r--rust/controller/flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/rust/controller/flake.nix b/rust/controller/flake.nix
new file mode 100644
index 0000000..7f8cad7
--- /dev/null
+++ b/rust/controller/flake.nix
@@ -0,0 +1,22 @@
+{
+ description = "A very basic flake";
+
+ outputs = { self, nixpkgs }:
+ let
+ system = "x86_64-linux";
+ pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ devShell.${system} = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ SDL2
+ glibc
+ pkgconfig
+ ];
+ };
+
+ packages.x86_64-linux.hello = nixpkgs.legacyPackages.x86_64-linux.hello;
+
+ defaultPackage.x86_64-linux = self.packages.x86_64-linux.hello;
+
+ };
+}