summaryrefslogtreecommitdiff
path: root/clisp/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'clisp/flake.nix')
-rw-r--r--clisp/flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/clisp/flake.nix b/clisp/flake.nix
new file mode 100644
index 0000000..644371b
--- /dev/null
+++ b/clisp/flake.nix
@@ -0,0 +1,17 @@
+{
+ description = "A basic flake";
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ };
+
+ outputs = { self, nixpkgs }:
+ let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in
+ {
+ devShell.x86_64-linux = pkgs.mkShell rec {
+ buildInputs = with pkgs; [ sbcl openssl ];
+ LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath buildInputs;
+ };
+ };
+}