summaryrefslogtreecommitdiff
path: root/clisp/flake.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2024-02-25 14:46:22 -0500
committerKjetil Orbekk <kj@orbekk.com>2024-02-25 14:46:22 -0500
commit116dc5f0b548a43390ee13636b2d372c07af3702 (patch)
tree88d7b2aeba1619a25a694dc08082ae35b1d4ade5 /clisp/flake.nix
parent465c3a1045625d12a73e723651ae9bd9b0a51cb1 (diff)
update
Diffstat (limited to 'clisp/flake.nix')
-rw-r--r--clisp/flake.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/clisp/flake.nix b/clisp/flake.nix
new file mode 100644
index 0000000..644371b
--- /dev/null
+++ b/clisp/flake.nix
@@ -0,0 +1,17 @@
+{
+ description = "A basic flake";
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ };
+
+ outputs = { self, nixpkgs }:
+ let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in
+ {
+ devShell.x86_64-linux = pkgs.mkShell rec {
+ buildInputs = with pkgs; [ sbcl openssl ];
+ LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath buildInputs;
+ };
+ };
+}