summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index e82436ae11..a04e251b51 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,14 +1,16 @@
{ avr ? true, arm ? true, teensy ? true }:
let
# We specify sources via Niv: use "niv update nixpkgs" to update nixpkgs, for example.
- sources = import ./nix/sources.nix {};
- pkgs = import sources.nixpkgs {};
+ sources = import ./nix/sources.nix { };
+ pkgs = import sources.nixpkgs { };
+
+ poetry2nix = pkgs.callPackage (import sources.poetry2nix) { };
# Builds the python env based on nix/pyproject.toml and
# nix/poetry.lock Use the "poetry update --lock", "poetry add
# --lock" etc. in the nix folder to adjust the contents of those
# files if the requirements*.txt files change
- pythonEnv = pkgs.poetry2nix.mkPoetryEnv {
+ pythonEnv = poetry2nix.mkPoetryEnv {
projectDir = ./nix;
};
in