summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAndré Silva <123550+andresilva@users.noreply.github.com>2021-03-25 11:45:55 +0000
committerGitHub <noreply@github.com>2021-03-25 22:45:55 +1100
commitef872595ae3c89bd2f59f18a9053af3536240bac (patch)
treebaca6a32ee757ecaabb2a6fba0b8630424af0841 /shell.nix
parenteac9ee8d3fb3f9f6eec4314fbab20fa3c4ed2edb (diff)
update shell.nix (#12295)
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix36
1 files changed, 4 insertions, 32 deletions
diff --git a/shell.nix b/shell.nix
index 82505d5d27..ab44dd8e31 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,48 +2,20 @@
let
nixpkgs = builtins.fetchTarball {
- url = "https://github.com/NixOS/nixpkgs/archive/c4b26e702044dbf40f8236136c099d8ab6778514.tar.gz";
- sha256 = "0w6hgs01qzni3a7cvgadjlmcdlb6vay3w910vh4k9fc949ii7s60";
+ url = "https://github.com/NixOS/nixpkgs/archive/1f77a4c8c74bbe896053994836790aa9bf6dc5ba.tar.gz";
+ sha256 = "1j62nmzz3w33dplzf1xz1pg1pfkxii7lwdqmsxmc71cs9cm3s7n1";
};
pkgs = import nixpkgs { };
- hjson = with pkgs.python3Packages; buildPythonPackage rec {
- pname = "hjson";
- version = "3.0.1";
-
- src = fetchPypi {
- inherit pname version;
- sha256 = "1yaimcgz8w0ps1wk28wk9g9zdidp79d14xqqj9rjkvxalvx2f5qx";
- };
-
- doCheck = false;
- };
-
- milc = with pkgs.python3Packages; buildPythonPackage rec {
- pname = "milc";
- version = "1.0.10";
-
- src = fetchPypi {
- inherit pname version;
- sha256 = "1q1p7qrqk78mw67nhv04zgxaq8himmdxmy2vp4fmi7chwgcbpi32";
- };
-
- propagatedBuildInputs = [
- appdirs
- argcomplete
- colorama
- ];
-
- doCheck = false;
- };
-
pythonEnv = pkgs.python3.withPackages (p: with p; [
# requirements.txt
appdirs
argcomplete
colorama
+ dotty-dict
hjson
+ jsonschema
milc
pygments
# requirements-dev.txt