summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorSergey Vlasov <sigprof@gmail.com>2022-07-18 22:52:55 +0300
committerGitHub <noreply@github.com>2022-07-18 22:52:55 +0300
commit627e35b7ac61e294c7c34a693d8191cded68136e (patch)
tree4861d78ca882d2a5c1f0b8fde99cf91e7d3be81c /shell.nix
parentc10d0fc785a8c8972bc129c6db03e26360eddd45 (diff)
Remove Nixpkgs-provided `poetry` from the environment (#17673)
The `poetry` package from the used Nixpkgs snapshot triggers the regex compatibility issue in Nix >= 2.10.0 binaries for `x86_64-darwin`: https://www.github.com/NixOS/nix/issues/4758 Remove the `poetry` package from the Nix shell environment for now (it is not really required to compile QMK, only to develop the Nix shell environment itself). In addition, all `poetry` version earlier than 1.1.14 became effectively non-functional after a breaking change of the PyPI JSON API: https://www.github.com/python-poetry/poetry/pull/5973 Updating the `poetry` package is not trivial (just adding it it to `pyproject.toml` does not work due to dependency version conflicts with other modules), therefore removing it seems to be the easiest solution to restore compatibility with new Nix versions while not creating any major inconvenience for QMK users.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index a96aa840de..7e3704d010 100644
--- a/shell.nix
+++ b/shell.nix
@@ -48,7 +48,7 @@ in
mkShell {
name = "qmk-firmware";
- buildInputs = [ clang-tools dfu-programmer dfu-util diffutils git pythonEnv poetry niv ]
+ buildInputs = [ clang-tools dfu-programmer dfu-util diffutils git pythonEnv niv ]
++ lib.optional avr [
pkgsCross.avr.buildPackages.binutils
pkgsCross.avr.buildPackages.gcc8