summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorQMK Bot <hello@qmk.fm>2021-08-29 21:25:08 +0000
committerQMK Bot <hello@qmk.fm>2021-08-29 21:25:08 +0000
commit532bff7b6cc2c2e932ae331293203871cb03268d (patch)
treed46d05a42babd66ced901a7c1c586d27cc4f5923 /shell.nix
parentd227c8692a30749cc3bc6ad1939ad9b59d3bbc3f (diff)
parenta1866a962c21a6e15f40cbde2bd09c0ff42f1454 (diff)
Merge remote-tracking branch 'origin/master' into develop
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
index 74656032a5..c36df032de 100644
--- a/shell.nix
+++ b/shell.nix
@@ -12,6 +12,13 @@ let
# files if the requirements*.txt files change
pythonEnv = poetry2nix.mkPoetryEnv {
projectDir = ./util/nix;
+ overrides = poetry2nix.overrides.withDefaults (self: super: {
+ qmk = super.qmk.overridePythonAttrs(old: {
+ # Allow QMK CLI to run "bin/qmk" as a subprocess (the wrapper changes
+ # $PATH and breaks these invocations).
+ dontWrapPythonPrograms = true;
+ });
+ });
};
in