summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAndré Silva <123550+andresilva@users.noreply.github.com>2021-01-14 19:29:00 +0000
committerGitHub <noreply@github.com>2021-01-14 11:29:00 -0800
commit345a041cf54d93cb35eabf429a6d99ae603760c4 (patch)
treef38759ece08a66948dd7ad9e23f5cc5b3946a263 /shell.nix
parente9f73e54548a0eae05f62bebe25ea8cdd79dd991 (diff)
allow customizing decrease delay of rgb heatmap (#11322)
* allow customizing decrease delay of rgb heatmap * rename rgb typing heatmap decrease delay variable * address review comments * nix-shell: add clang-tools required for formatting the C code * heatmap: use real timer to track decrement rate * heatmap: fix ifndef var name typo * heatmap: add docs * Update docs/feature_rgb_matrix.md Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 6cfda2da9a..82505d5d27 100644
--- a/shell.nix
+++ b/shell.nix
@@ -71,7 +71,7 @@ in
mkShell {
name = "qmk-firmware";
- buildInputs = [ dfu-programmer dfu-util diffutils git pythonEnv ]
+ buildInputs = [ clang-tools dfu-programmer dfu-util diffutils git pythonEnv ]
++ lib.optional avr [
pkgsCross.avr.buildPackages.binutils
pkgsCross.avr.buildPackages.gcc8