summaryrefslogtreecommitdiff
path: root/keyboards/splitkb/aurora
diff options
context:
space:
mode:
authorNick Brassel <nick@tzarc.org>2023-12-18 16:05:50 +1100
committerGitHub <noreply@github.com>2023-12-18 16:05:50 +1100
commitd235352504f82eae5dedc399bae36c65f1348fa8 (patch)
tree775021fd419c2099ab75d7aa6481924290894b35 /keyboards/splitkb/aurora
parentf25226453fb253b5d1c2f1684365d6248d8b5750 (diff)
Remove obvious user keymaps, `keyboards/{b,c}*` edition. (#22693)
Diffstat (limited to 'keyboards/splitkb/aurora')
-rw-r--r--keyboards/splitkb/aurora/corne/keymaps/debug/config.h21
-rw-r--r--keyboards/splitkb/aurora/corne/keymaps/debug/keymap.c73
-rw-r--r--keyboards/splitkb/aurora/corne/keymaps/debug/readme.md24
-rw-r--r--keyboards/splitkb/aurora/corne/keymaps/debug/rules.mk23
-rw-r--r--keyboards/splitkb/aurora/helix/keymaps/debug/config.h19
-rw-r--r--keyboards/splitkb/aurora/helix/keymaps/debug/keymap.c68
-rw-r--r--keyboards/splitkb/aurora/helix/keymaps/debug/readme.md24
-rw-r--r--keyboards/splitkb/aurora/helix/keymaps/debug/rules.mk8
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/config.h21
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c75
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md24
-rw-r--r--keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk23
-rw-r--r--keyboards/splitkb/aurora/sofle_v2/keymaps/debug/config.h19
-rw-r--r--keyboards/splitkb/aurora/sofle_v2/keymaps/debug/keymap.c69
-rw-r--r--keyboards/splitkb/aurora/sofle_v2/keymaps/debug/readme.md24
-rw-r--r--keyboards/splitkb/aurora/sofle_v2/keymaps/debug/rules.mk8
-rw-r--r--keyboards/splitkb/aurora/sweep/keymaps/debug/config.h21
-rw-r--r--keyboards/splitkb/aurora/sweep/keymaps/debug/keymap.c77
-rw-r--r--keyboards/splitkb/aurora/sweep/keymaps/debug/readme.md25
-rw-r--r--keyboards/splitkb/aurora/sweep/keymaps/debug/rules.mk23
20 files changed, 0 insertions, 669 deletions
diff --git a/keyboards/splitkb/aurora/corne/keymaps/debug/config.h b/keyboards/splitkb/aurora/corne/keymaps/debug/config.h
deleted file mode 100644
index 9e639dbc35..0000000000
--- a/keyboards/splitkb/aurora/corne/keymaps/debug/config.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#ifdef RGBLIGHT_ENABLE
-# define RGBLIGHT_EFFECT_BREATHING
-#endif
diff --git a/keyboards/splitkb/aurora/corne/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/corne/keymaps/debug/keymap.c
deleted file mode 100644
index dc145ee042..0000000000
--- a/keyboards/splitkb/aurora/corne/keymaps/debug/keymap.c
+++ /dev/null
@@ -1,73 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include QMK_KEYBOARD_H
-
-enum layers {
- _DEFAULT = 0,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_DEFAULT] = LAYOUT_split_3x6_3(
- KC_A, KC_B, KC_C, KC_D, KC_E, KC_F, S(KC_F), S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
- KC_G, KC_H, KC_I, KC_J, KC_K, KC_L, S(KC_L), S(KC_K), S(KC_J), S(KC_I), S(KC_H), S(KC_G),
- KC_M, KC_N, KC_O, KC_P, KC_Q, KC_R, S(KC_R), S(KC_Q), S(KC_P), S(KC_O), S(KC_N), S(KC_M),
- KC_S, KC_T, KC_U, S(KC_U), S(KC_T), S(KC_S)
- )
-};
-
-#ifdef RGBLIGHT_ENABLE
-void keyboard_post_init_user(void) {
- rgblight_enable_noeeprom(); // enables RGB, without saving settings
- rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
- rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
-}
-#endif
-
-#ifdef ENCODER_ENABLE
-bool encoder_update_user(uint8_t index, bool clockwise) {
- // 0 is left-half encoder,
- // 1 is right-half encoder
- if (index == 0) {
- tap_code(KC_0);
- } else if (index == 1) {
- tap_code(KC_1);
- }
-
- if (clockwise) {
- tap_code16(KC_PLUS);
- } else {
- tap_code(KC_MINUS);
- }
-
- return false;
-}
-#endif
-
-#ifdef OLED_ENABLE
-bool oled_task_user(void) {
- // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
- // This example string should fill that neatly
- const char *text = PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?");
-
- if (is_keyboard_master()) {
- oled_write_P(text, false);
- } else {
- oled_write_P(text, false);
- }
- return false;
-}
-#endif
diff --git a/keyboards/splitkb/aurora/corne/keymaps/debug/readme.md b/keyboards/splitkb/aurora/corne/keymaps/debug/readme.md
deleted file mode 100644
index 5384fdaacf..0000000000
--- a/keyboards/splitkb/aurora/corne/keymaps/debug/readme.md
+++ /dev/null
@@ -1,24 +0,0 @@
-# Aurora Corne's Debug Keymap
-
-To make debugging your build as easy as possible, we have provided a special debugging keymap. It is not intended to actually type on, it is just here to make sure that your hardware is working correctly.
-
-## Keys
-
-![Keys](https://i.imgur.com/y5zWjsZh.png)
-
-The left side uses lowercase letters, the right side uses uppercase ones.
-
-## Encoders
-
-Encoders output a number of 0 or 1, depending on the installed position.
-These correspond to the index used for custom encoder code.
-
-The number is followed by either a `+` or a `-`, depending on the direction turned.
-
-## LEDs
-
-Both underglow and per-key RGB should be fading between red and off.
-
-## OLEDs
-
-Both the primary and secondary side should be filled with characters.
diff --git a/keyboards/splitkb/aurora/corne/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/corne/keymaps/debug/rules.mk
deleted file mode 100644
index c8a3944323..0000000000
--- a/keyboards/splitkb/aurora/corne/keymaps/debug/rules.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2022 splitkb.com <support@splitkb.com>
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-# NOTE: These are already enabled by default at the revision level
-#ENCODER_ENABLE = yes
-#OLED_ENABLE = yes
-
-# RGB Matrix is enabled at the revision level,
-# while we use the regular RGB underglow for testing
-RGB_MATRIX_ENABLE = no
-RGBLIGHT_ENABLE = yes
diff --git a/keyboards/splitkb/aurora/helix/keymaps/debug/config.h b/keyboards/splitkb/aurora/helix/keymaps/debug/config.h
deleted file mode 100644
index a15def3fb9..0000000000
--- a/keyboards/splitkb/aurora/helix/keymaps/debug/config.h
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright 2023 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#define RGBLIGHT_EFFECT_BREATHING \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/helix/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/helix/keymaps/debug/keymap.c
deleted file mode 100644
index 2c99ef9429..0000000000
--- a/keyboards/splitkb/aurora/helix/keymaps/debug/keymap.c
+++ /dev/null
@@ -1,68 +0,0 @@
-/* Copyright 2023 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include QMK_KEYBOARD_H
-
-enum layers {
- _DEFAULT = 0,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_DEFAULT] = LAYOUT(
- KC_A, KC_B, KC_C, KC_D, KC_E, KC_F, S(KC_F), S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
- KC_G, KC_H, KC_I, KC_J, KC_K, KC_L, S(KC_L), S(KC_K), S(KC_J), S(KC_I), S(KC_H), S(KC_G),
- KC_M, KC_N, KC_O, KC_P, KC_Q, KC_R, S(KC_R), S(KC_Q), S(KC_P), S(KC_O), S(KC_N), S(KC_M),
- KC_S, KC_T, KC_U, KC_V, KC_W, KC_X, KC_Y, S(KC_Y), S(KC_X), S(KC_W), S(KC_V), S(KC_U), S(KC_T), S(KC_S),
- KC_Z, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, S(KC_6), S(KC_5), S(KC_4), S(KC_3), S(KC_2), S(KC_1), S(KC_Z)
- )
-};
-
-#ifdef RGBLIGHT_ENABLE
-void keyboard_post_init_user(void) {
- rgblight_enable_noeeprom(); // enables RGB, without saving settings
- rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
- rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
-}
-#endif
-
-#ifdef ENCODER_ENABLE
-bool encoder_update_user(uint8_t index, bool clockwise) {
- // 0 is left-half encoder
- // 1 is right-half encoder
- if (index == 0) {
- tap_code(KC_0);
- } else if (index == 1) {
- tap_code(KC_1);
- }
-
- if (clockwise) {
- tap_code16(KC_PLUS);
- } else {
- tap_code(KC_MINUS);
- }
-
- return false;
-}
-#endif
-
-#ifdef OLED_ENABLE
-bool oled_task_user(void) {
- // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
- // This example string should fill that neatly
- oled_write_P(PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?"), false);
- return false;
-}
-#endif \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/helix/keymaps/debug/readme.md b/keyboards/splitkb/aurora/helix/keymaps/debug/readme.md
deleted file mode 100644
index 827235e447..0000000000
--- a/keyboards/splitkb/aurora/helix/keymaps/debug/readme.md
+++ /dev/null
@@ -1,24 +0,0 @@
-# Aurora Helix's Debug Keymap
-
-To make debugging your build as easy as possible, we have provided a special debugging keymap. It is not intended to actually type on, it is just here to make sure that your hardware is working correctly.
-
-## Keys
-
-![Keys](https://raw.githubusercontent.com/splitkb/qmk_firmware/assets/aurora/keymaps/debug/keys.png)
-
-The left side uses lowercase letters, the right side uses uppercase ones.
-
-## Encoders
-
-Encoders output a number of 0 or 1, depending on the installed position.
-These correspond to the index used for custom encoder code: the left half uses index 0, the right half uses index 1.
-
-The number is followed by either a `+` or a `-`, depending on the direction turned.
-
-## LEDs
-
-Both underglow and per-key RGB should be fading between red and off.
-
-## OLEDs
-
-Both the primary and secondary side should be filled with characters. \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/helix/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/helix/keymaps/debug/rules.mk
deleted file mode 100644
index 9c9df9b126..0000000000
--- a/keyboards/splitkb/aurora/helix/keymaps/debug/rules.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-# NOTE: These are already enabled by default at the revision level
-#ENCODER_ENABLE = yes
-#OLED_ENABLE = yes
-
-# RGB Matrix is enabled at the revision level,
-# while we use the regular RGB underglow for testing
-RGB_MATRIX_ENABLE = no
-RGBLIGHT_ENABLE = yes \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h b/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h
deleted file mode 100644
index 9e639dbc35..0000000000
--- a/keyboards/splitkb/aurora/lily58/keymaps/debug/config.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#ifdef RGBLIGHT_ENABLE
-# define RGBLIGHT_EFFECT_BREATHING
-#endif
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c
deleted file mode 100644
index 0bd2fa9370..0000000000
--- a/keyboards/splitkb/aurora/lily58/keymaps/debug/keymap.c
+++ /dev/null
@@ -1,75 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include QMK_KEYBOARD_H
-
-enum layers {
- _DEFAULT = 0,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_DEFAULT] = LAYOUT(
- KC_A, KC_B, KC_C, KC_D, KC_E, KC_F, S(KC_F), S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
- KC_G, KC_H, KC_I, KC_J, KC_K, KC_L, S(KC_L), S(KC_K), S(KC_J), S(KC_I), S(KC_H), S(KC_G),
- KC_M, KC_N, KC_O, KC_P, KC_Q, KC_R, S(KC_R), S(KC_Q), S(KC_P), S(KC_O), S(KC_N), S(KC_M),
- KC_S, KC_T, KC_U, KC_V, KC_W, KC_X, KC_Y, S(KC_Y), S(KC_X), S(KC_W), S(KC_V), S(KC_U), S(KC_T), S(KC_S),
- KC_Z, KC_1, KC_2, KC_3, S(KC_3), S(KC_2), S(KC_1), S(KC_Z)
-
- )
-};
-
-#ifdef RGBLIGHT_ENABLE
-void keyboard_post_init_user(void) {
- rgblight_enable_noeeprom(); // enables RGB, without saving settings
- rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
- rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
-}
-#endif
-
-#ifdef ENCODER_ENABLE
-bool encoder_update_user(uint8_t index, bool clockwise) {
- // 0 is left-half encoder
- // 1 is right-half encoder
- if (index == 0) {
- tap_code(KC_0);
- } else if (index == 1) {
- tap_code(KC_1);
- }
-
- if (clockwise) {
- tap_code16(KC_PLUS);
- } else {
- tap_code(KC_MINUS);
- }
-
- return false;
-}
-#endif
-
-#ifdef OLED_ENABLE
-bool oled_task_user(void) {
- // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
- // This example string should fill that neatly
- const char *text = PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?");
-
- if (is_keyboard_master()) {
- oled_write_P(text, false);
- } else {
- oled_write_P(text, false);
- }
- return false;
-}
-#endif
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md b/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md
deleted file mode 100644
index 8c51d64842..0000000000
--- a/keyboards/splitkb/aurora/lily58/keymaps/debug/readme.md
+++ /dev/null
@@ -1,24 +0,0 @@
-# Aurora Lily58's Debug Keymap
-
-To make debugging your build as easy as possible, we have provided a special debugging keymap. It is not intended to actually type on, it is just here to make sure that your hardware is working correctly.
-
-## Keys
-
-![Keys](https://i.imgur.com/CF0PYu5h.png)
-
-The left side uses lowercase letters, the right side uses uppercase ones.
-
-## Encoders
-
-Encoders output a number of 0 or 1, depending on the installed position.
-These correspond to the index used for custom encoder code: the left half uses index 0, the right half uses index 1.
-
-The number is followed by either a `+` or a `-`, depending on the direction turned.
-
-## LEDs
-
-Both underglow and per-key RGB should be fading between red and off.
-
-## OLEDs
-
-Both the primary and secondary side should be filled with characters.
diff --git a/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk
deleted file mode 100644
index c8a3944323..0000000000
--- a/keyboards/splitkb/aurora/lily58/keymaps/debug/rules.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2022 splitkb.com <support@splitkb.com>
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-# NOTE: These are already enabled by default at the revision level
-#ENCODER_ENABLE = yes
-#OLED_ENABLE = yes
-
-# RGB Matrix is enabled at the revision level,
-# while we use the regular RGB underglow for testing
-RGB_MATRIX_ENABLE = no
-RGBLIGHT_ENABLE = yes
diff --git a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/config.h b/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/config.h
deleted file mode 100644
index a15def3fb9..0000000000
--- a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/config.h
+++ /dev/null
@@ -1,19 +0,0 @@
-/* Copyright 2023 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#define RGBLIGHT_EFFECT_BREATHING \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/keymap.c
deleted file mode 100644
index b9383db325..0000000000
--- a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/keymap.c
+++ /dev/null
@@ -1,69 +0,0 @@
-/* Copyright 2023 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include QMK_KEYBOARD_H
-
-enum layers {
- _DEFAULT = 0,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_DEFAULT] = LAYOUT(
- KC_A, KC_B, KC_C, KC_D, KC_E, KC_F, S(KC_F), S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
- KC_G, KC_H, KC_I, KC_J, KC_K, KC_L, S(KC_L), S(KC_K), S(KC_J), S(KC_I), S(KC_H), S(KC_G),
- KC_M, KC_N, KC_O, KC_P, KC_Q, KC_R, S(KC_R), S(KC_Q), S(KC_P), S(KC_O), S(KC_N), S(KC_M),
- KC_S, KC_T, KC_U, KC_V, KC_W, KC_X, KC_Y, S(KC_Y), S(KC_X), S(KC_W), S(KC_V), S(KC_U), S(KC_T), S(KC_S),
- KC_Z, KC_1, KC_2, KC_3, KC_4, S(KC_4), S(KC_3), S(KC_2), S(KC_1), S(KC_Z)
-
- )
-};
-
-#ifdef RGBLIGHT_ENABLE
-void keyboard_post_init_user(void) {
- rgblight_enable_noeeprom(); // enables RGB, without saving settings
- rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
- rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
-}
-#endif
-
-#ifdef ENCODER_ENABLE
-bool encoder_update_user(uint8_t index, bool clockwise) {
- // 0 is left-half encoder
- // 1 is right-half encoder
- if (index == 0) {
- tap_code(KC_0);
- } else if (index == 1) {
- tap_code(KC_1);
- }
-
- if (clockwise) {
- tap_code16(KC_PLUS);
- } else {
- tap_code(KC_MINUS);
- }
-
- return false;
-}
-#endif
-
-#ifdef OLED_ENABLE
-bool oled_task_user(void) {
- // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
- // This example string should fill that neatly
- oled_write_P(PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?"), false);
- return false;
-}
-#endif \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/readme.md b/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/readme.md
deleted file mode 100644
index c429b0246d..0000000000
--- a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/readme.md
+++ /dev/null
@@ -1,24 +0,0 @@
-# Aurora Sofle's Debug Keymap
-
-To make debugging your build as easy as possible, we have provided a special debugging keymap. It is not intended to actually type on, it is just here to make sure that your hardware is working correctly.
-
-## Keys
-
-![Keys](https://i.imgur.com/1qRAV6sh.png)
-
-The left side uses lowercase letters, the right side uses uppercase ones.
-
-## Encoders
-
-Encoders output a number of 0 or 1, depending on the installed position.
-These correspond to the index used for custom encoder code: the left half uses index 0, the right half uses index 1.
-
-The number is followed by either a `+` or a `-`, depending on the direction turned.
-
-## LEDs
-
-Both underglow and per-key RGB should be fading between red and off.
-
-## OLEDs
-
-Both the primary and secondary side should be filled with characters. \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/rules.mk
deleted file mode 100644
index 9c9df9b126..0000000000
--- a/keyboards/splitkb/aurora/sofle_v2/keymaps/debug/rules.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-# NOTE: These are already enabled by default at the revision level
-#ENCODER_ENABLE = yes
-#OLED_ENABLE = yes
-
-# RGB Matrix is enabled at the revision level,
-# while we use the regular RGB underglow for testing
-RGB_MATRIX_ENABLE = no
-RGBLIGHT_ENABLE = yes \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/sweep/keymaps/debug/config.h b/keyboards/splitkb/aurora/sweep/keymaps/debug/config.h
deleted file mode 100644
index 9e639dbc35..0000000000
--- a/keyboards/splitkb/aurora/sweep/keymaps/debug/config.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#pragma once
-
-#ifdef RGBLIGHT_ENABLE
-# define RGBLIGHT_EFFECT_BREATHING
-#endif
diff --git a/keyboards/splitkb/aurora/sweep/keymaps/debug/keymap.c b/keyboards/splitkb/aurora/sweep/keymaps/debug/keymap.c
deleted file mode 100644
index 5bdc5f2b42..0000000000
--- a/keyboards/splitkb/aurora/sweep/keymaps/debug/keymap.c
+++ /dev/null
@@ -1,77 +0,0 @@
-/* Copyright 2022 splitkb.com <support@splitkb.com>
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include QMK_KEYBOARD_H
-
-enum layers {
- _DEFAULT = 0,
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [_DEFAULT] = LAYOUT(
- KC_A, KC_B, KC_C, KC_D, KC_E, S(KC_E), S(KC_D), S(KC_C), S(KC_B), S(KC_A),
- KC_F, KC_G, KC_H, KC_I, KC_J, S(KC_J), S(KC_I), S(KC_H), S(KC_G), S(KC_F),
- KC_K, KC_L, KC_M, KC_N, KC_O, S(KC_O), S(KC_N), S(KC_M), S(KC_L), S(KC_K),
- KC_P, KC_Q, S(KC_Q), S(KC_P)
- )
-};
-
-#ifdef RGBLIGHT_ENABLE
-void keyboard_post_init_user(void) {
- rgblight_enable_noeeprom(); // enables RGB, without saving settings
- rgblight_sethsv_noeeprom(HSV_RED); // sets the color to red without saving
- rgblight_mode_noeeprom(RGBLIGHT_MODE_BREATHING + 3); // sets mode to Fast breathing without saving
-}
-#endif
-
-#ifdef ENCODER_ENABLE
-bool encoder_update_user(uint8_t index, bool clockwise) {
- // 0 and 1 are left-half encoders
- // 2 and 3 are right-half encoders
- if (index == 0) {
- tap_code(KC_0);
- } else if (index == 1) {
- tap_code(KC_1);
- } else if (index == 2) {
- tap_code(KC_2);
- } else if (index == 3) {
- tap_code(KC_3);
- }
-
- if (clockwise) {
- tap_code16(KC_PLUS);
- } else {
- tap_code(KC_MINUS);
- }
-
- return false;
-}
-#endif
-
-#ifdef OLED_ENABLE
-bool oled_task_user(void) {
- // A 128x32 OLED rotated 90 degrees is 5 characters wide and 16 characters tall
- // This example string should fill that neatly
- const char *text = PSTR("abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ123456789!@#$%^&*()[]{}-=_+?");
-
- if (is_keyboard_master()) {
- oled_write_P(text, false);
- } else {
- oled_write_P(text, false);
- }
- return false;
-}
-#endif
diff --git a/keyboards/splitkb/aurora/sweep/keymaps/debug/readme.md b/keyboards/splitkb/aurora/sweep/keymaps/debug/readme.md
deleted file mode 100644
index 6d4d5aaff6..0000000000
--- a/keyboards/splitkb/aurora/sweep/keymaps/debug/readme.md
+++ /dev/null
@@ -1,25 +0,0 @@
-# Aurora Sweep's Debug Keymap
-
-Due to the complex layer setup, the default keymap for the Aurora Sweep is relatively hard to debug.
-This debug keymap should make that a lot easier.
-
-## Keys
-
-![Keys](https://raw.githubusercontent.com/splitkb/qmk_firmware/assets/aurora/sweep/keymaps/debug/keys.png)
-
-The left side uses lowercase letters, the right side uses uppercase ones.
-
-## Encoders
-
-Encoders output a number of 0 to 3, depending on the installed position.
-These correspond to the index used for custom encoder code.
-
-The number is followed by either a `+` or a `-`, depending on the direction turned.
-
-## LEDs
-
-Both underglow and per-key RGB should be fading between red and off.
-
-## OLEDs
-
-Both the primary and secondary side should be filled with characters.
diff --git a/keyboards/splitkb/aurora/sweep/keymaps/debug/rules.mk b/keyboards/splitkb/aurora/sweep/keymaps/debug/rules.mk
deleted file mode 100644
index c8a3944323..0000000000
--- a/keyboards/splitkb/aurora/sweep/keymaps/debug/rules.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2022 splitkb.com <support@splitkb.com>
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-# NOTE: These are already enabled by default at the revision level
-#ENCODER_ENABLE = yes
-#OLED_ENABLE = yes
-
-# RGB Matrix is enabled at the revision level,
-# while we use the regular RGB underglow for testing
-RGB_MATRIX_ENABLE = no
-RGBLIGHT_ENABLE = yes