summaryrefslogtreecommitdiff
path: root/keyboards/splitkb/aurora/lily58/rev1
diff options
context:
space:
mode:
authorleah-splitkb <103112489+leah-splitkb@users.noreply.github.com>2022-12-06 16:57:50 +0100
committerGitHub <noreply@github.com>2022-12-06 15:57:50 +0000
commit0e93b0d59be24933d69756dae44fc02c979b466f (patch)
tree586f8812cf52193339a99eaa1f78f3dfe959adff /keyboards/splitkb/aurora/lily58/rev1
parent2709b6ed616f8012ff4cfd3ee69a822a8d188351 (diff)
[Keyboard] Add splitkb.com's Aurora Lily58 (#19183)
Diffstat (limited to 'keyboards/splitkb/aurora/lily58/rev1')
-rw-r--r--keyboards/splitkb/aurora/lily58/rev1/config.h45
-rw-r--r--keyboards/splitkb/aurora/lily58/rev1/info.json195
-rw-r--r--keyboards/splitkb/aurora/lily58/rev1/rev1.c37
-rw-r--r--keyboards/splitkb/aurora/lily58/rev1/rules.mk17
4 files changed, 294 insertions, 0 deletions
diff --git a/keyboards/splitkb/aurora/lily58/rev1/config.h b/keyboards/splitkb/aurora/lily58/rev1/config.h
new file mode 100644
index 0000000000..d443782713
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/rev1/config.h
@@ -0,0 +1,45 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+// `SPLIT_HAND_PIN` can currently be defined in `info.json`,
+// but can't yet be given a value
+#define SPLIT_HAND_PIN F5
+
+// Not yet available in `info.json`
+#ifdef OLED_ENABLE
+# define OLED_DISPLAY_128X32
+# define SPLIT_OLED_ENABLE
+#endif
+
+// Not yet available in `info.json`
+#ifdef RGB_MATRIX_ENABLE
+# define RGB_MATRIX_MAXIMUM_BRIGHTNESS RGBLIGHT_LIMIT_VAL
+# define RGB_MATRIX_LED_COUNT RGBLED_NUM
+# define RGB_MATRIX_SPLIT RGBLED_SPLIT
+# define SPLIT_TRANSPORT_MIRROR
+#endif
+
+// Not yet available in `info.json`
+#ifdef BOOTMAGIC_ENABLE
+ // Top left key on left half
+# define BOOTMAGIC_LITE_ROW 0
+# define BOOTMAGIC_LITE_COLUMN 0
+ // Top right key on right half
+# define BOOTMAGIC_LITE_ROW_RIGHT 5
+# define BOOTMAGIC_LITE_COLUMN_RIGHT 0
+#endif
diff --git a/keyboards/splitkb/aurora/lily58/rev1/info.json b/keyboards/splitkb/aurora/lily58/rev1/info.json
new file mode 100644
index 0000000000..4a6a05ff63
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/rev1/info.json
@@ -0,0 +1,195 @@
+{
+ "keyboard_name": "Aurora Lily58 rev1",
+ "usb": {
+ "pid": "0xB4C2"
+ },
+ "features": {
+ "mousekey": true,
+ "bootmagic": true,
+ "extrakey": true,
+ "oled": true,
+ "rgb_matrix": true
+ },
+ "layouts": {
+ "LAYOUT": {
+ "layout": [
+ {"label": "L01", "matrix": [0, 0], "x": 0, "y": 0.5},
+ {"label": "L02", "matrix": [0, 1], "x": 1, "y": 0.375},
+ {"label": "L03", "matrix": [0, 2], "x": 2, "y": 0.125},
+ {"label": "L04", "matrix": [0, 3], "x": 3, "y": 0},
+ {"label": "L05", "matrix": [0, 4], "x": 4, "y": 0.125},
+ {"label": "L06", "matrix": [0, 5], "x": 5, "y": 0.25},
+ {"label": "R06", "matrix": [5, 5], "x": 10.5, "y": 0.25},
+ {"label": "R05", "matrix": [5, 4], "x": 11.5, "y": 0.125},
+ {"label": "R04", "matrix": [5, 3], "x": 12.5, "y": 0},
+ {"label": "R03", "matrix": [5, 2], "x": 13.5, "y": 0.125},
+ {"label": "R02", "matrix": [5, 1], "x": 14.5, "y": 0.375},
+ {"label": "R01", "matrix": [5, 0], "x": 15.5, "y": 0.5},
+
+ {"label": "L07", "matrix": [1, 0], "x": 0, "y": 1.5},
+ {"label": "L08", "matrix": [1, 1], "x": 1, "y": 1.375},
+ {"label": "L09", "matrix": [1, 2], "x": 2, "y": 1.125},
+ {"label": "L10", "matrix": [1, 3], "x": 3, "y": 1},
+ {"label": "L11", "matrix": [1, 4], "x": 4, "y": 1.125},
+ {"label": "L12", "matrix": [1, 5], "x": 5, "y": 1.25},
+ {"label": "R12", "matrix": [6, 5], "x": 10.5, "y": 1.25},
+ {"label": "R11", "matrix": [6, 4], "x": 11.5, "y": 1.125},
+ {"label": "R10", "matrix": [6, 3], "x": 12.5, "y": 1},
+ {"label": "R09", "matrix": [6, 2], "x": 13.5, "y": 1.125},
+ {"label": "R08", "matrix": [6, 1], "x": 14.5, "y": 1.375},
+ {"label": "R07", "matrix": [6, 0], "x": 15.5, "y": 1.5},
+
+ {"label": "L13", "matrix": [2, 0], "x": 0, "y": 2.5},
+ {"label": "L14", "matrix": [2, 1], "x": 1, "y": 2.375},
+ {"label": "L15", "matrix": [2, 2], "x": 2, "y": 2.125},
+ {"label": "L16", "matrix": [2, 3], "x": 3, "y": 2},
+ {"label": "L17", "matrix": [2, 4], "x": 4, "y": 2.125},
+ {"label": "L18", "matrix": [2, 5], "x": 5, "y": 2.25},
+ {"label": "R18", "matrix": [7, 5], "x": 10.5, "y": 2.25},
+ {"label": "R17", "matrix": [7, 4], "x": 11.5, "y": 2.125},
+ {"label": "R16", "matrix": [7, 3], "x": 12.5, "y": 2},
+ {"label": "R15", "matrix": [7, 2], "x": 13.5, "y": 2.125},
+ {"label": "R14", "matrix": [7, 1], "x": 14.5, "y": 2.375},
+ {"label": "R13", "matrix": [7, 0], "x": 15.5, "y": 2.5},
+
+ {"label": "L20", "matrix": [3, 0], "x": 0, "y": 3.5},
+ {"label": "L21", "matrix": [3, 1], "x": 1, "y": 3.375},
+ {"label": "L22", "matrix": [3, 2], "x": 2, "y": 3.125},
+ {"label": "L23", "matrix": [3, 3], "x": 3, "y": 3},
+ {"label": "L24", "matrix": [3, 4], "x": 4, "y": 3.125},
+ {"label": "L25", "matrix": [3, 5], "x": 5, "y": 3.25},
+ {"label": "L19", "matrix": [4, 1], "x": 6, "y": 2.75},
+ {"label": "R19", "matrix": [9, 1], "x": 9.5, "y": 2.75},
+ {"label": "R25", "matrix": [8, 5], "x": 10.5, "y": 3.25},
+ {"label": "R24", "matrix": [8, 4], "x": 11.5, "y": 3.125},
+ {"label": "R23", "matrix": [8, 3], "x": 12.5, "y": 3},
+ {"label": "R22", "matrix": [8, 2], "x": 13.5, "y": 3.125},
+ {"label": "R21", "matrix": [8, 1], "x": 14.5, "y": 3.375},
+ {"label": "R20", "matrix": [8, 0], "x": 15.5, "y": 3.5},
+
+ {"label": "L26", "matrix": [4, 2], "x": 2.5, "y": 4.15},
+ {"label": "L27", "matrix": [4, 3], "x": 3.5, "y": 4.15},
+ {"label": "L28", "matrix": [4, 4], "x": 4.5, "y": 4.25},
+ {"label": "L29", "matrix": [4, 5], "x": 6, "y": 4.25},
+ {"label": "R29", "matrix": [9, 5], "x": 9.5, "y": 4.25},
+ {"label": "R28", "matrix": [9, 4], "x": 11, "y": 4.25},
+ {"label": "R27", "matrix": [9, 3], "x": 12, "y": 4.15},
+ {"label": "R26", "matrix": [9, 2], "x": 13, "y": 4.15}
+ ]
+ }
+ },
+ "diode_direction": "ROW2COL",
+ "matrix_pins": {
+ "rows": ["F4", "F6", "D7", "E6", "B4"],
+ "cols": ["B5", "F7", "B1", "B3", "B2", "B6"]
+ },
+ "encoder": {
+ "enabled": true,
+ "rotary": [
+ {
+ "pin_a": "C6",
+ "pin_b": "D4"
+ }
+ ]
+ },
+ "split": {
+ "soft_serial_pin": "D2",
+ "main": "matrix_grid",
+ "matrix_pins": {
+ "right": {
+ "rows": ["F4", "D4", "B3", "B2", "B6"],
+ "cols": ["B1", "C6", "D7", "E6", "B4", "B5"]
+ }
+ },
+ "encoder": {
+ "right": {
+ "rotary": [
+ {
+ "pin_a": "F7",
+ "pin_b": "F6"
+ }
+ ]
+ }
+ }
+ },
+ "rgblight": {
+ "pin": "D3",
+ "led_count": 68,
+ "split": true,
+ "split_count": [34, 34],
+ "max_brightness": 128
+ },
+ "rgb_matrix": {
+ "driver": "WS2812",
+ "layout": [
+ {"flags": 2, "x": 51, "y": 13}, // L RGB1
+ {"flags": 2, "x": 22, "y": 18}, // L RGB2
+ {"flags": 2, "x": 22, "y": 53}, // L RGB3
+ {"flags": 2, "x": 58, "y": 60}, // L RGB4
+ {"flags": 2, "x": 87, "y": 56}, // L RGB5
+ {"flags": 4, "matrix": [0, 0], "x": 0, "y": 8}, // L SW01
+ {"flags": 4, "matrix": [0, 1], "x": 14, "y": 6}, // L SW02
+ {"flags": 4, "matrix": [0, 2], "x": 29, "y": 2}, // L SW03
+ {"flags": 4, "matrix": [0, 3], "x": 43, "y": 0}, // L SW04
+ {"flags": 4, "matrix": [0, 4], "x": 58, "y": 2}, // L SW05
+ {"flags": 4, "matrix": [0, 5], "x": 72, "y": 4}, // L SW06
+ {"flags": 4, "matrix": [1, 0], "x": 0, "y": 23}, // L SW07
+ {"flags": 4, "matrix": [1, 1], "x": 14, "y": 21}, // L SW08
+ {"flags": 4, "matrix": [1, 2], "x": 29, "y": 17}, // L SW09
+ {"flags": 4, "matrix": [1, 3], "x": 43, "y": 15}, // L SW10
+ {"flags": 4, "matrix": [1, 4], "x": 58, "y": 17}, // L SW11
+ {"flags": 4, "matrix": [1, 5], "x": 72, "y": 19}, // L SW12
+ {"flags": 4, "matrix": [2, 0], "x": 0, "y": 38}, // L SW13
+ {"flags": 4, "matrix": [2, 1], "x": 14, "y": 36}, // L SW14
+ {"flags": 4, "matrix": [2, 2], "x": 29, "y": 32}, // L SW15
+ {"flags": 4, "matrix": [2, 3], "x": 43, "y": 30}, // L SW16
+ {"flags": 4, "matrix": [2, 4], "x": 58, "y": 32}, // L SW17
+ {"flags": 4, "matrix": [2, 5], "x": 72, "y": 34}, // L SW18
+ {"flags": 4, "matrix": [3, 0], "x": 0, "y": 53}, // L SW20
+ {"flags": 4, "matrix": [3, 1], "x": 14, "y": 51}, // L SW21
+ {"flags": 4, "matrix": [3, 2], "x": 29, "y": 47}, // L SW22
+ {"flags": 4, "matrix": [3, 3], "x": 43, "y": 45}, // L SW23
+ {"flags": 4, "matrix": [3, 4], "x": 58, "y": 47}, // L SW24
+ {"flags": 4, "matrix": [3, 5], "x": 72, "y": 49}, // L SW25
+ {"flags": 4, "matrix": [4, 1], "x": 87, "y": 41}, // L SW19
+ {"flags": 4, "matrix": [4, 2], "x": 36, "y": 62}, // L SW26
+ {"flags": 4, "matrix": [4, 3], "x": 51, "y": 62}, // L SW27
+ {"flags": 4, "matrix": [4, 4], "x": 65, "y": 64}, // L SW28
+ {"flags": 4, "matrix": [4, 5], "x": 87, "y": 64}, // L SW29
+ {"flags": 2, "x": 173, "y": 13}, // R RGB1
+ {"flags": 2, "x": 202, "y": 18}, // R RGB2
+ {"flags": 2, "x": 202, "y": 53}, // R RGB3
+ {"flags": 2, "x": 166, "y": 60}, // R RGB4
+ {"flags": 2, "x": 137, "y": 56}, // R RGB5
+ {"flags": 4, "matrix": [5, 5], "x": 152, "y": 4}, // R SW06
+ {"flags": 4, "matrix": [5, 4], "x": 166, "y": 2}, // R SW05
+ {"flags": 4, "matrix": [5, 3], "x": 181, "y": 0}, // R SW04
+ {"flags": 4, "matrix": [5, 2], "x": 195, "y": 2}, // R SW03
+ {"flags": 4, "matrix": [5, 1], "x": 210, "y": 6}, // R SW02
+ {"flags": 4, "matrix": [5, 0], "x": 224, "y": 8}, // R SW01
+ {"flags": 4, "matrix": [6, 5], "x": 152, "y": 19}, // R SW12
+ {"flags": 4, "matrix": [6, 4], "x": 166, "y": 17}, // R SW11
+ {"flags": 4, "matrix": [6, 3], "x": 181, "y": 15}, // R SW10
+ {"flags": 4, "matrix": [6, 2], "x": 195, "y": 17}, // R SW09
+ {"flags": 4, "matrix": [6, 1], "x": 210, "y": 21}, // R SW08
+ {"flags": 4, "matrix": [6, 0], "x": 224, "y": 23}, // R SW07
+ {"flags": 4, "matrix": [7, 5], "x": 152, "y": 34}, // R SW18
+ {"flags": 4, "matrix": [7, 4], "x": 166, "y": 32}, // R SW17
+ {"flags": 4, "matrix": [7, 3], "x": 181, "y": 30}, // R SW16
+ {"flags": 4, "matrix": [7, 2], "x": 195, "y": 32}, // R SW15
+ {"flags": 4, "matrix": [7, 1], "x": 210, "y": 36}, // R SW14
+ {"flags": 4, "matrix": [7, 0], "x": 224, "y": 38}, // R SW13
+ {"flags": 4, "matrix": [9, 1], "x": 137, "y": 41}, // R SW19
+ {"flags": 4, "matrix": [8, 5], "x": 152, "y": 49}, // R SW25
+ {"flags": 4, "matrix": [8, 4], "x": 166, "y": 47}, // R SW24
+ {"flags": 4, "matrix": [8, 3], "x": 181, "y": 45}, // R SW23
+ {"flags": 4, "matrix": [8, 2], "x": 195, "y": 47}, // R SW22
+ {"flags": 4, "matrix": [8, 1], "x": 210, "y": 51}, // R SW21
+ {"flags": 4, "matrix": [8, 0], "x": 224, "y": 53}, // R SW20
+ {"flags": 4, "matrix": [9, 5], "x": 137, "y": 64}, // R SW29
+ {"flags": 4, "matrix": [9, 4], "x": 159, "y": 64}, // R SW28
+ {"flags": 4, "matrix": [9, 3], "x": 173, "y": 62}, // R SW27
+ {"flags": 4, "matrix": [9, 2], "x": 188, "y": 62}, // R SW26
+ ]
+ }
+}
diff --git a/keyboards/splitkb/aurora/lily58/rev1/rev1.c b/keyboards/splitkb/aurora/lily58/rev1/rev1.c
new file mode 100644
index 0000000000..d6f0a1153b
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/rev1/rev1.c
@@ -0,0 +1,37 @@
+/* Copyright 2022 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include QMK_KEYBOARD_H
+
+#ifdef SWAP_HANDS_ENABLE
+// clang-format off
+ __attribute__ ((weak)) const keypos_t PROGMEM hand_swap_config[MATRIX_ROWS][MATRIX_COLS] = {
+ {{0, 5}, {1, 5}, {2, 5}, {3, 5}, {4, 5}, {5, 5}},
+ {{0, 6}, {1, 6}, {2, 6}, {3, 6}, {4, 6}, {5, 6}},
+ {{0, 7}, {1, 7}, {2, 7}, {3, 7}, {4, 7}, {5, 7}},
+ {{0, 8}, {1, 8}, {2, 8}, {3, 8}, {4, 8}, {5, 8}},
+ {{0, 9}, {1, 9}, {2, 9}, {3, 9}, {4, 9}, {5, 9}},
+ {{0, 0}, {1, 0}, {2, 0}, {3, 0}, {4, 0}, {5, 0}},
+ {{0, 1}, {1, 1}, {2, 1}, {3, 1}, {4, 1}, {5, 1}},
+ {{0, 2}, {1, 2}, {2, 2}, {3, 2}, {4, 2}, {5, 2}},
+ {{0, 3}, {1, 3}, {2, 3}, {3, 3}, {4, 3}, {5, 3}},
+ {{0, 4}, {1, 4}, {2, 4}, {3, 4}, {4, 4}, {5, 4}}
+ };
+// clang-format on
+# ifdef ENCODER_MAP_ENABLE
+ const uint8_t PROGMEM encoder_hand_swap_config[NUM_ENCODERS] = {1,0};
+# endif
+#endif
diff --git a/keyboards/splitkb/aurora/lily58/rev1/rules.mk b/keyboards/splitkb/aurora/lily58/rev1/rules.mk
new file mode 100644
index 0000000000..dd52338283
--- /dev/null
+++ b/keyboards/splitkb/aurora/lily58/rev1/rules.mk
@@ -0,0 +1,17 @@
+# Copyright 2022 splitkb.com <support@splitkb.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Although no rules are defined,
+# presence of this file is required for QMK to compile it.