summaryrefslogtreecommitdiff
path: root/keyboards/splitkb/aurora/helix/rev1
diff options
context:
space:
mode:
authorharveysch <126267034+harveysch@users.noreply.github.com>2023-09-15 20:34:21 +0200
committerGitHub <noreply@github.com>2023-09-15 11:34:21 -0700
commite7ae5ec07c7655e0087c6a4cfcb2cbfec4713536 (patch)
treeba0b041c136d3636ebd9288c6a26c00a4feb7168 /keyboards/splitkb/aurora/helix/rev1
parent49f1cbd40eae67cde4c5fb03fe8c0db1e9522956 (diff)
[Keyboard] Add splitkb.com's Aurora Helix (#21871)
Co-authored-by: Less/Rikki <86894501+lesshonor@users.noreply.github.com> Co-authored-by: Ryan <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/splitkb/aurora/helix/rev1')
-rw-r--r--keyboards/splitkb/aurora/helix/rev1/config.h24
-rw-r--r--keyboards/splitkb/aurora/helix/rev1/info.json206
-rw-r--r--keyboards/splitkb/aurora/helix/rev1/rev1.c56
-rw-r--r--keyboards/splitkb/aurora/helix/rev1/rules.mk0
4 files changed, 286 insertions, 0 deletions
diff --git a/keyboards/splitkb/aurora/helix/rev1/config.h b/keyboards/splitkb/aurora/helix/rev1/config.h
new file mode 100644
index 0000000000..bbf6c50073
--- /dev/null
+++ b/keyboards/splitkb/aurora/helix/rev1/config.h
@@ -0,0 +1,24 @@
+/* Copyright 2023 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+#define SPLIT_HAND_PIN D3
+
+#define OLED_DISPLAY_128X32
+#define SPLIT_OLED_ENABLE
+
+#define RGB_MATRIX_LED_COUNT 76 \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/helix/rev1/info.json b/keyboards/splitkb/aurora/helix/rev1/info.json
new file mode 100644
index 0000000000..7c6acf0070
--- /dev/null
+++ b/keyboards/splitkb/aurora/helix/rev1/info.json
@@ -0,0 +1,206 @@
+{
+ "keyboard_name": "Aurora Helix rev1",
+ "diode_direction": "COL2ROW",
+ "encoder": {
+ "enabled": true,
+ "rotary": [
+ {"pin_a": "E6", "pin_b": "B4"}
+ ]
+ },
+ "features": {
+ "bootmagic": true,
+ "extrakey": true,
+ "mousekey": true,
+ "oled": true,
+ "rgb_matrix": true
+ },
+ "matrix_pins": {
+ "cols": ["F6", "F7", "B1", "B3", "B2", "B6", "B5"],
+ "rows": ["F4", "F5", "D4", "C6", "D7"]
+ },
+ "rgb_matrix": {
+ "driver": "ws2812",
+ "layout": [
+ {"x": 72, "y": 16, "flags": 2},
+ {"x": 40, "y": 16, "flags": 2},
+ {"x": 8, "y": 16, "flags": 2},
+ {"x": 8, "y": 48, "flags": 2},
+ {"x": 40, "y": 48, "flags": 2},
+ {"x": 72, "y": 48, "flags": 2},
+ {"matrix": [0, 5], "x": 80, "y": 0, "flags": 4},
+ {"matrix": [0, 4], "x": 64, "y": 0, "flags": 4},
+ {"matrix": [0, 3], "x": 48, "y": 0, "flags": 4},
+ {"matrix": [0, 2], "x": 32, "y": 0, "flags": 4},
+ {"matrix": [0, 1], "x": 16, "y": 0, "flags": 4},
+ {"matrix": [0, 0], "x": 0, "y": 0, "flags": 4},
+ {"matrix": [1, 5], "x": 80, "y": 16, "flags": 4},
+ {"matrix": [1, 4], "x": 64, "y": 16, "flags": 4},
+ {"matrix": [1, 3], "x": 48, "y": 16, "flags": 4},
+ {"matrix": [1, 2], "x": 32, "y": 16, "flags": 4},
+ {"matrix": [1, 1], "x": 16, "y": 16, "flags": 4},
+ {"matrix": [1, 0], "x": 0, "y": 16, "flags": 4},
+ {"matrix": [2, 5], "x": 80, "y": 32, "flags": 4},
+ {"matrix": [2, 4], "x": 64, "y": 32, "flags": 4},
+ {"matrix": [2, 3], "x": 48, "y": 32, "flags": 4},
+ {"matrix": [2, 2], "x": 32, "y": 32, "flags": 4},
+ {"matrix": [2, 1], "x": 16, "y": 32, "flags": 4},
+ {"matrix": [2, 0], "x": 0, "y": 32, "flags": 4},
+ {"matrix": [3, 6], "x": 96, "y": 48, "flags": 4},
+ {"matrix": [3, 5], "x": 80, "y": 48, "flags": 4},
+ {"matrix": [3, 4], "x": 64, "y": 48, "flags": 4},
+ {"matrix": [3, 3], "x": 48, "y": 48, "flags": 4},
+ {"matrix": [3, 2], "x": 32, "y": 48, "flags": 4},
+ {"matrix": [3, 1], "x": 16, "y": 48, "flags": 4},
+ {"matrix": [3, 0], "x": 0, "y": 48, "flags": 4},
+ {"matrix": [4, 6], "x": 96, "y": 64, "flags": 4},
+ {"matrix": [4, 5], "x": 80, "y": 64, "flags": 4},
+ {"matrix": [4, 4], "x": 64, "y": 64, "flags": 4},
+ {"matrix": [4, 3], "x": 48, "y": 64, "flags": 4},
+ {"matrix": [4, 2], "x": 32, "y": 64, "flags": 4},
+ {"matrix": [4, 1], "x": 16, "y": 64, "flags": 4},
+ {"matrix": [4, 0], "x": 0, "y": 64, "flags": 4},
+ {"x": 152, "y": 16, "flags": 2},
+ {"x": 184, "y": 16, "flags": 2},
+ {"x": 216, "y": 16, "flags": 2},
+ {"x": 216, "y": 48, "flags": 2},
+ {"x": 184, "y": 48, "flags": 2},
+ {"x": 152, "y": 48, "flags": 2},
+ {"matrix": [5, 5], "x": 144, "y": 0, "flags": 4},
+ {"matrix": [5, 4], "x": 160, "y": 0, "flags": 4},
+ {"matrix": [5, 3], "x": 176, "y": 0, "flags": 4},
+ {"matrix": [5, 2], "x": 192, "y": 0, "flags": 4},
+ {"matrix": [5, 1], "x": 208, "y": 0, "flags": 4},
+ {"matrix": [5, 0], "x": 224, "y": 0, "flags": 4},
+ {"matrix": [6, 5], "x": 144, "y": 16, "flags": 4},
+ {"matrix": [6, 4], "x": 160, "y": 16, "flags": 4},
+ {"matrix": [6, 3], "x": 176, "y": 16, "flags": 4},
+ {"matrix": [6, 2], "x": 192, "y": 16, "flags": 4},
+ {"matrix": [6, 1], "x": 208, "y": 16, "flags": 4},
+ {"matrix": [6, 0], "x": 224, "y": 16, "flags": 4},
+ {"matrix": [7, 5], "x": 144, "y": 32, "flags": 4},
+ {"matrix": [7, 4], "x": 160, "y": 32, "flags": 4},
+ {"matrix": [7, 3], "x": 176, "y": 32, "flags": 4},
+ {"matrix": [7, 2], "x": 192, "y": 32, "flags": 4},
+ {"matrix": [7, 1], "x": 208, "y": 32, "flags": 4},
+ {"matrix": [7, 0], "x": 224, "y": 32, "flags": 4},
+ {"matrix": [8, 6], "x": 128, "y": 48, "flags": 4},
+ {"matrix": [8, 5], "x": 144, "y": 48, "flags": 4},
+ {"matrix": [8, 4], "x": 160, "y": 48, "flags": 4},
+ {"matrix": [8, 3], "x": 176, "y": 48, "flags": 4},
+ {"matrix": [8, 2], "x": 192, "y": 48, "flags": 4},
+ {"matrix": [8, 1], "x": 208, "y": 48, "flags": 4},
+ {"matrix": [8, 0], "x": 224, "y": 48, "flags": 4},
+ {"matrix": [9, 6], "x": 128, "y": 64, "flags": 4},
+ {"matrix": [9, 5], "x": 144, "y": 64, "flags": 4},
+ {"matrix": [9, 4], "x": 160, "y": 64, "flags": 4},
+ {"matrix": [9, 3], "x": 176, "y": 64, "flags": 4},
+ {"matrix": [9, 2], "x": 192, "y": 64, "flags": 4},
+ {"matrix": [9, 1], "x": 208, "y": 64, "flags": 4},
+ {"matrix": [9, 0], "x": 224, "y": 64, "flags": 4}
+ ],
+ "max_brightness": 128,
+ "split_count": [38, 38]
+ },
+ "rgblight": {
+ "led_count": 76,
+ "max_brightness": 128,
+ "split": true,
+ "split_count": [38, 38]
+ },
+ "split": {
+ "bootmagic": {
+ "matrix": [7, 0]
+ },
+ "encoder": {
+ "right": {
+ "rotary": [
+ {"pin_a": "B2", "pin_b": "B3"}
+ ]
+ }
+ },
+ "main": "matrix_grid",
+ "matrix_pins": {
+ "right": {
+ "cols": ["D4", "C6", "D7", "E6", "B4", "B5", "B6"],
+ "rows": ["F4", "F5", "F6", "F7", "B1"]
+ }
+ },
+ "soft_serial_pin": "D2"
+ },
+ "usb": {
+ "pid": "0xB4C4"
+ },
+ "ws2812": {
+ "pin": "D3"
+ },
+ "layouts": {
+ "LAYOUT": {
+ "layout": [
+ {"label": "L01", "matrix": [0, 0], "x": 0, "y": 0},
+ {"label": "L02", "matrix": [0, 1], "x": 1, "y": 0},
+ {"label": "L03", "matrix": [0, 2], "x": 2, "y": 0},
+ {"label": "L04", "matrix": [0, 3], "x": 3, "y": 0},
+ {"label": "L05", "matrix": [0, 4], "x": 4, "y": 0},
+ {"label": "L06", "matrix": [0, 5], "x": 5, "y": 0},
+ {"label": "R06", "matrix": [5, 5], "x": 9, "y": 0},
+ {"label": "R05", "matrix": [5, 4], "x": 10, "y": 0},
+ {"label": "R04", "matrix": [5, 3], "x": 11, "y": 0},
+ {"label": "R03", "matrix": [5, 2], "x": 12, "y": 0},
+ {"label": "R02", "matrix": [5, 1], "x": 13, "y": 0},
+ {"label": "R01", "matrix": [5, 0], "x": 14, "y": 0},
+ {"label": "L07", "matrix": [1, 0], "x": 0, "y": 1},
+ {"label": "L08", "matrix": [1, 1], "x": 1, "y": 1},
+ {"label": "L09", "matrix": [1, 2], "x": 2, "y": 1},
+ {"label": "L10", "matrix": [1, 3], "x": 3, "y": 1},
+ {"label": "L11", "matrix": [1, 4], "x": 4, "y": 1},
+ {"label": "L12", "matrix": [1, 5], "x": 5, "y": 1},
+ {"label": "R12", "matrix": [6, 5], "x": 9, "y": 1},
+ {"label": "R11", "matrix": [6, 4], "x": 10, "y": 1},
+ {"label": "R10", "matrix": [6, 3], "x": 11, "y": 1},
+ {"label": "R09", "matrix": [6, 2], "x": 12, "y": 1},
+ {"label": "R08", "matrix": [6, 1], "x": 13, "y": 1},
+ {"label": "R07", "matrix": [6, 0], "x": 14, "y": 1},
+ {"label": "L13", "matrix": [2, 0], "x": 0, "y": 2},
+ {"label": "L14", "matrix": [2, 1], "x": 1, "y": 2},
+ {"label": "L15", "matrix": [2, 2], "x": 2, "y": 2},
+ {"label": "L16", "matrix": [2, 3], "x": 3, "y": 2},
+ {"label": "L17", "matrix": [2, 4], "x": 4, "y": 2},
+ {"label": "L18", "matrix": [2, 5], "x": 5, "y": 2},
+ {"label": "R18", "matrix": [7, 5], "x": 9, "y": 2},
+ {"label": "R17", "matrix": [7, 4], "x": 10, "y": 2},
+ {"label": "R16", "matrix": [7, 3], "x": 11, "y": 2},
+ {"label": "R15", "matrix": [7, 2], "x": 12, "y": 2},
+ {"label": "R14", "matrix": [7, 1], "x": 13, "y": 2},
+ {"label": "R13", "matrix": [7, 0], "x": 14, "y": 2},
+ {"label": "L19", "matrix": [3, 0], "x": 0, "y": 3},
+ {"label": "L20", "matrix": [3, 1], "x": 1, "y": 3},
+ {"label": "L21", "matrix": [3, 2], "x": 2, "y": 3},
+ {"label": "L22", "matrix": [3, 3], "x": 3, "y": 3},
+ {"label": "L23", "matrix": [3, 4], "x": 4, "y": 3},
+ {"label": "L24", "matrix": [3, 5], "x": 5, "y": 3},
+ {"label": "L25", "matrix": [3, 6], "x": 6, "y": 3},
+ {"label": "R25", "matrix": [8, 6], "x": 8, "y": 3},
+ {"label": "R24", "matrix": [8, 5], "x": 9, "y": 3},
+ {"label": "R23", "matrix": [8, 4], "x": 10, "y": 3},
+ {"label": "R22", "matrix": [8, 3], "x": 11, "y": 3},
+ {"label": "R21", "matrix": [8, 2], "x": 12, "y": 3},
+ {"label": "R20", "matrix": [8, 1], "x": 13, "y": 3},
+ {"label": "R19", "matrix": [8, 0], "x": 14, "y": 3},
+ {"label": "L26", "matrix": [4, 0], "x": 0, "y": 4},
+ {"label": "L27", "matrix": [4, 1], "x": 1, "y": 4},
+ {"label": "L28", "matrix": [4, 2], "x": 2, "y": 4},
+ {"label": "L29", "matrix": [4, 3], "x": 3, "y": 4},
+ {"label": "L30", "matrix": [4, 4], "x": 4, "y": 4},
+ {"label": "L31", "matrix": [4, 5], "x": 5, "y": 4},
+ {"label": "L32", "matrix": [4, 6], "x": 6, "y": 4},
+ {"label": "R32", "matrix": [9, 6], "x": 8, "y": 4},
+ {"label": "R31", "matrix": [9, 5], "x": 9, "y": 4},
+ {"label": "R30", "matrix": [9, 4], "x": 10, "y": 4},
+ {"label": "R29", "matrix": [9, 3], "x": 11, "y": 4},
+ {"label": "R28", "matrix": [9, 2], "x": 12, "y": 4},
+ {"label": "R27", "matrix": [9, 1], "x": 13, "y": 4},
+ {"label": "R26", "matrix": [9, 0], "x": 14, "y": 4}
+ ]
+ }
+ }
+} \ No newline at end of file
diff --git a/keyboards/splitkb/aurora/helix/rev1/rev1.c b/keyboards/splitkb/aurora/helix/rev1/rev1.c
new file mode 100644
index 0000000000..da24934eef
--- /dev/null
+++ b/keyboards/splitkb/aurora/helix/rev1/rev1.c
@@ -0,0 +1,56 @@
+/* Copyright 2023 splitkb.com <support@splitkb.com>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include QMK_KEYBOARD_H
+
+// Overriding is_keyboard_left() in qmk_firmware/quantum/split_common/split_util.c to limit the handedness check only once.
+// reason: SPLIT_HAND_PIN is shared with the RGB pin so we don't want to keep reusing the pin for handedness checks.
+bool is_keyboard_left(void) {
+static enum { UNKNOWN, LEFT, RIGHT } hand_side = UNKNOWN;
+ // only check once, as this is called often
+ if (hand_side == UNKNOWN) {
+ #if defined(SPLIT_HAND_PIN)
+ // Test pin SPLIT_HAND_PIN for High/Low, if low it's right hand
+ setPinInput(SPLIT_HAND_PIN);
+ hand_side = readPin(SPLIT_HAND_PIN) ? LEFT : RIGHT;
+ return (hand_side == LEFT);
+ #endif
+ hand_side = is_keyboard_master() ? LEFT : RIGHT;
+ return (hand_side == LEFT);
+ } else {
+ return (hand_side == LEFT);
+ }
+}
+
+#ifdef SWAP_HANDS_ENABLE
+// clang-format off
+ __attribute__ ((weak)) const keypos_t PROGMEM hand_swap_config[MATRIX_ROWS][MATRIX_COLS] = {
+ {{0, 5}, {1, 5}, {2, 5}, {3, 5}, {4, 5}, {5, 5}, {6, 5}},
+ {{0, 6}, {1, 6}, {2, 6}, {3, 6}, {4, 6}, {5, 6}, {6, 6}},
+ {{0, 7}, {1, 7}, {2, 7}, {3, 7}, {4, 7}, {5, 7}, {6, 7}},
+ {{0, 8}, {1, 8}, {2, 8}, {3, 8}, {4, 8}, {5, 8}, {6, 8}},
+ {{0, 9}, {1, 9}, {2, 9}, {3, 9}, {4, 9}, {5, 9}, {6, 9}},
+ {{0, 0}, {1, 0}, {2, 0}, {3, 0}, {4, 0}, {5, 0}, {6, 0}},
+ {{0, 1}, {1, 1}, {2, 1}, {3, 1}, {4, 1}, {5, 1}, {6, 1}},
+ {{0, 2}, {1, 2}, {2, 2}, {3, 2}, {4, 2}, {5, 2}, {6, 2}},
+ {{0, 3}, {1, 3}, {2, 3}, {3, 3}, {4, 3}, {5, 3}, {6, 3}},
+ {{0, 4}, {1, 4}, {2, 4}, {3, 4}, {4, 4}, {5, 4}, {6, 4}}
+ };
+// clang-format on
+# ifdef ENCODER_MAP_ENABLE
+ const uint8_t PROGMEM encoder_hand_swap_config[NUM_ENCODERS] = {1,0};
+# endif
+#endif
diff --git a/keyboards/splitkb/aurora/helix/rev1/rules.mk b/keyboards/splitkb/aurora/helix/rev1/rules.mk
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/keyboards/splitkb/aurora/helix/rev1/rules.mk