summaryrefslogtreecommitdiff
path: root/keyboards/cannonkeys/gentoo_hs/rules.mk
diff options
context:
space:
mode:
authorQMK Bot <hello@qmk.fm>2022-07-02 22:19:13 +0000
committerQMK Bot <hello@qmk.fm>2022-07-02 22:19:13 +0000
commit8744d5757847084e248ddd34eb7f7a50be1314a0 (patch)
treee199fa1a10d903ffc0628034be0e7386665236ea /keyboards/cannonkeys/gentoo_hs/rules.mk
parent5f11d7b554ac1697585828658d127bddb34d1521 (diff)
parent43e33ba232a02f627c4fcc6607edd6f7971e71b8 (diff)
Merge remote-tracking branch 'origin/master' into develop
Diffstat (limited to 'keyboards/cannonkeys/gentoo_hs/rules.mk')
-rw-r--r--keyboards/cannonkeys/gentoo_hs/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/cannonkeys/gentoo_hs/rules.mk b/keyboards/cannonkeys/gentoo_hs/rules.mk
new file mode 100644
index 0000000000..b34d15f4b5
--- /dev/null
+++ b/keyboards/cannonkeys/gentoo_hs/rules.mk
@@ -0,0 +1,24 @@
+# MCU name
+MCU = STM32F072
+
+# Bootloader selection
+BOOTLOADER = stm32-dfu
+
+# Wildcard to allow APM32 MCU
+DFU_SUFFIX_ARGS = -v FFFF -p FFFF
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = yes # Enable Bootmagic Lite
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Enable N-Key Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+AUDIO_ENABLE = no # Audio output
+
+# Enter lower-power sleep mode when on the ChibiOS idle thread
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE