summaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/package.nix b/package.nix
new file mode 100644
index 0000000..f315641
--- /dev/null
+++ b/package.nix
@@ -0,0 +1,45 @@
+{ callPackage, fetchFromGitHub, makeRustPlatform, stdenv, pkgs, ... }:
+
+let mkRustPlatform = { date, channel }:
+ let
+ mozillaOverlay = fetchFromGitHub {
+ owner = "mozilla";
+ repo = "nixpkgs-mozilla";
+ rev = "5300241b41243cb8962fad284f0004afad187dad";
+ sha256 = "1h3g3817anicwa9705npssvkwhi876zijyyvv4c86qiklrkn5j9w";
+ };
+ mozilla = callPackage "${mozillaOverlay.out}/package-set.nix" {};
+ rustSpecific = (mozilla.rustChannelOf { inherit date channel; }).rust;
+ in
+ makeRustPlatform {
+ cargo = rustSpecific;
+ rustc = rustSpecific;
+ };
+in let
+ rustPlatform = mkRustPlatform {
+ date = "2020-01-15";
+ channel = "nightly";
+ };
+in rustPlatform.buildRustPackage rec {
+ pname = "pjournal";
+ version = "0.1.0";
+
+ # https://git.breakds.org/breakds/nixvital/src/branch/master/pkgs/simple-reflection-server/default.nix
+ postInstall = ''
+ mkdir $out/etc/
+ cp -r templates $out/etc
+ wrapProgram "$out/bin/simple-reflection-server" \
+ --prefix ROCKET_TEMPLATE_DIR : "$out/etc/templates"
+ '';
+
+ buildInputs = with pkgs; [
+ openssl pkgconfig postgresql
+ ];
+
+ src = ./.;
+
+ cargoSha256 = "1s2cix5a74g0cwfw93sak8mx7yrxba476fz89zgpz01y57wzgybr";
+ # verifyCargoDeps = true;
+}
+
+