summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2020-01-28 21:18:50 -0500
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2020-01-28 21:18:50 -0500
commit94cbd545217d85f6e975131ee70a26194b7fdb3c (patch)
tree36e788b6554662db8e2fdcfd9358d9afc6d57384 /shell.nix
Initial rocket app framework
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..99825a3
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.stdenv.mkDerivation {
+ name = "pjournal";
+ buildInputs = with pkgs; [
+ rustup
+ clang
+ openssl
+ sqlite
+ pkgconfig
+ ];
+}