summaryrefslogtreecommitdiff
path: root/util/install/debian.sh
diff options
context:
space:
mode:
authorStefan Kerkmann <karlk90@pm.me>2021-10-18 07:23:20 +0200
committerGitHub <noreply@github.com>2021-10-18 16:23:20 +1100
commite50867d52d9c255570630a23514842749b45e4c1 (patch)
treee448e47262668e21084fb7439a38b0322136bb89 /util/install/debian.sh
parent7e3ff206b8600265ea086040b397f1a600c4a7f3 (diff)
[Core] Add support for RISC-V builds and GD32VF103 MCU (#12508)
* Add support for RISC-V builds and GD32VF103 MCU * Add toolchain selection in chibios.mk based on the mcu selected in mcu_selection.mk * Reorder and added comments to chibios.mk to have a streamlined makefile * Add GD32VF103 mcu to possible targets for QMK. * Add STM32 compatibility for GD32VF103 MCU, this is hacky but more efficent then rewriting every driver. * Add GigaDevice DFU bootloader as flash target, please note that dfu-util of at least version 0.10 is needed. * Add analog driver compatibility * Add apa102 bitbang driver compatibility * Add ws2812 bitbang driver compatibility * Add eeprom in flash emulation compatibility * Allow faster re-builds with ccache * Add SiPeed Longan Nano to platform files * Add SiPeed Longan Nano Onekeys * Make quine compatible with other bootloaders * Support builds with picolibc * Add risc-v toolchain to arch and debian/ubuntu scripts
Diffstat (limited to 'util/install/debian.sh')
-rwxr-xr-xutil/install/debian.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/util/install/debian.sh b/util/install/debian.sh
index 57588e371a..2a188334b6 100755
--- a/util/install/debian.sh
+++ b/util/install/debian.sh
@@ -15,7 +15,8 @@ _qmk_install() {
build-essential clang-format diffutils gcc git unzip wget zip \
python3-pip binutils-avr gcc-avr avr-libc binutils-arm-none-eabi \
gcc-arm-none-eabi libnewlib-arm-none-eabi avrdude dfu-programmer \
- dfu-util teensy-loader-cli libhidapi-hidraw0 libusb-dev
+ dfu-util teensy-loader-cli libhidapi-hidraw0 libusb-dev \
+ picolibc-riscv64-unknown-elf gcc-riscv64-unknown-elf binutils-riscv64-unknown-elf
python3 -m pip install --user -r $QMK_FIRMWARE_DIR/requirements.txt
}