summaryrefslogtreecommitdiff
path: root/modules/vpn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/vpn.nix')
-rw-r--r--modules/vpn.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/vpn.nix b/modules/vpn.nix
index 47c269c..92f6a8e 100644
--- a/modules/vpn.nix
+++ b/modules/vpn.nix
@@ -22,11 +22,12 @@ let
};
firelink = mkConfig "firelink" "2001";
pincer = mkConfig "pincer" "2002";
+ steamdeck = mkConfig "steamdeck" "2003";
};
mkPeer = hostConfig: {
inherit (hostConfig) publicKey endpoint;
- allowedIPs = if hostConfig.router && !cfg.is_server then [ "::/0" ] else hostConfig.ips;
+ allowedIPs = if hostConfig.router && !cfg.is_server then [ "${vpn-prefix}::/64" ] else hostConfig.ips;
};
getPeers = host: