summaryrefslogtreecommitdiff
path: root/modules/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/router.nix')
-rw-r--r--modules/router.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/modules/router.nix b/modules/router.nix
index 4d1b045..a43b8e6 100644
--- a/modules/router.nix
+++ b/modules/router.nix
@@ -71,7 +71,8 @@ let
};
networking.interfaces.lan-vport = {
ipv4.addresses = [{address = "172.20.100.1"; prefixLength = 24;}];
- ipv6.addresses = [{address = "2001:470:8e2e:100::1"; prefixLength = 64;}];
+ # Can I finally switch to Verizon ipv6?
+ # ipv6.addresses = [{address = "2001:470:8e2e:100::1"; prefixLength = 64;}];
};
networking.interfaces.servers-vport = {
ipv4.addresses = [{address = "172.20.20.1"; prefixLength = 24;}];
@@ -112,8 +113,8 @@ let
path = [ pkgs.iproute ];
script = ''
ip -6 rule add fwmark ${toString heMark} table he || true
- ip -6 route replace default dev he0 table he
- ip -6 route replace default dev he0 metric 1
+ # ip -6 route replace default dev he0 table he
+ # ip -6 route replace default dev he0 metric 1
# ip rule add fwmark ${toString vpnMark} table vpn || true
# ip -6 rule add fwmark ${toString vpnMark} table vpn || true
@@ -174,10 +175,11 @@ let
enable = true;
extraConfig = ''
noipv6rs
- noipv6
nohook resolv.conf
interface wan-vport
- dhcp
+ dhcp
+ ipv6rs
+ ia_pd 1/::/56 lan-vport/16/64
'';
};