summaryrefslogtreecommitdiff
path: root/modules/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/router.nix')
-rw-r--r--modules/router.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/router.nix b/modules/router.nix
index 29de644..d7cc3a0 100644
--- a/modules/router.nix
+++ b/modules/router.nix
@@ -109,8 +109,8 @@ let
ip -6 rule add fwmark ${toString heMark} table he || true
ip -6 route replace default dev he0 table he
- ip rule add fwmark ${toString vpnMark} table vpn || true
- ip -6 rule add fwmark ${toString vpnMark} table vpn || true
+ # ip rule add fwmark ${toString vpnMark} table vpn || true
+ # ip -6 rule add fwmark ${toString vpnMark} table vpn || true
ip rule add fwmark ${toString mullvadMark} table mullvad || true
ip -6 rule add fwmark ${toString mullvadMark} table mullvad || true
@@ -334,7 +334,7 @@ in {
age.secrets.dragon-wireguard-key.file = ./.
+ "/../secrets/dragon-wireguard-key.age";
networking.wireguard.interfaces.wg-vpn = {
- fwMark = "${toString vpnMark}";
+ # fwMark = "${toString vpnMark}";
socketNamespace = "router";
interfaceNamespace = "router";
ips = [ "${vpnPrefix}::1/128" ];