summaryrefslogtreecommitdiff
path: root/modules/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/common.nix')
-rw-r--r--modules/common.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/common.nix b/modules/common.nix
index aafc1b0..8ae3b06 100644
--- a/modules/common.nix
+++ b/modules/common.nix
@@ -23,6 +23,21 @@
];
environment.variables.EDITOR = "${pkgs.neovim}/bin/nvim";
+ # Select internationalisation properties.
+ i18n.defaultLocale = "en_US.UTF-8";
+
+ i18n.extraLocaleSettings = {
+ LC_ADDRESS = "en_US.UTF-8";
+ LC_IDENTIFICATION = "en_US.UTF-8";
+ LC_MEASUREMENT = "en_US.UTF-8";
+ LC_MONETARY = "en_US.UTF-8";
+ LC_NAME = "en_US.UTF-8";
+ LC_NUMERIC = "en_US.UTF-8";
+ LC_PAPER = "en_US.UTF-8";
+ LC_TELEPHONE = "en_US.UTF-8";
+ LC_TIME = "en_US.UTF-8";
+ };
+
# nix.settings = {
# keep-outputs = true;
# keep-derivations = true;
@@ -125,4 +140,6 @@
boot.tmp.cleanOnBoot = true;
nixpkgs.config.allowUnfree = true;
+ hardware.enableAllFirmware = true;
+ hardware.enableRedistributableFirmware = true;
}