summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index b23398a..e92c25b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,7 +15,8 @@
({config, pkgs, ...}: {
# Let 'nixos-version --json' know about the Git revision
# of this flake.
- system.configurationRevision = nixpkgs.lib.mkIf (self ? rev) self.rev;
+ system.configurationRevision =
+ if self ? rev then self.rev else "DIRTY";
# Add unstable packages.
nixpkgs.overlays = [