summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 371a36d..ed11cda 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,13 +1,14 @@
{
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.09";
- inputs.nixpkgs_unstable.url = "github:NixOS/nixpkgs/nixos-unstable";
+ inputs.nixpkgs-unstable.url = "github:NixOS/nixpkgs/nixos-unstable";
+ inputs.nixos-hardware.url = github:NixOS/nixos-hardware/master;
# TODO: Remove nix overlay when pull request is resolved:
# https://github.com/NixOS/nix/pull/4566
inputs.nix.url = "github:orbekk/nix/master";
inputs.nix.inputs.nixpkgs.follows = "nixpkgs";
- outputs = { self, nixpkgs, nixpkgs_unstable, nix }:
+ outputs = { self, nixpkgs, nixpkgs-unstable, nix, nixos-hardware }:
{
nixosConfigurations = let
mkConfig = { hostName
@@ -19,6 +20,7 @@
modules =
[
module
+ nixpkgs.nixosModules.notDetected
({config, pkgs, ...}: {
# Let 'nixos-version --json' know about the Git revision
# of this flake.
@@ -27,7 +29,13 @@
nixpkgs.overlays = [
# Add unstable packages.
- (final: prev: { unstable = nixpkgs_unstable.legacyPackages."x86_64-linux"; })
+ (final: prev: {
+ my-extras = {
+ inherit nixpkgs;
+ inherit nixpkgs-unstable;
+ inherit nixos-hardware;
+ };
+ })
# For git+file support with bare repo.
nix.overlay
(final: prev: { nixFlakes = final.nix; })