summaryrefslogtreecommitdiff
path: root/config/yubikey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/yubikey.nix')
-rw-r--r--config/yubikey.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/config/yubikey.nix b/config/yubikey.nix
index 4565306..5ff9e79 100644
--- a/config/yubikey.nix
+++ b/config/yubikey.nix
@@ -9,15 +9,15 @@ let
yubikey-personalization
gnupg
pinentry
- libu2f-host
];
in
{
- services.pcscd.enable = true;
+ services.pcscd.enable = lib.mkForce false;
services.udev.packages = with pkgs; [
- # libu2f-host
+ libu2f-host
yubikey-personalization
];
+ systemd.services.pcscd.after = ["multi-user.target"];
programs.gnupg.agent = {
enable = true;
@@ -45,11 +45,11 @@ in
environment = {
systemPackages = yubikey-pkgs;
- shellInit = ''
- export GPG_TTY="$(tty)"
- gpg-connect-agent /bye
- export SSH_AUTH_SOCK="/run/user/$UID/gnupg/S.gpg-agent.ssh"
- '';
+ # shellInit = ''
+ # export GPG_TTY="$(tty)"
+ # gpg-connect-agent /bye
+ # export SSH_AUTH_SOCK="/run/user/$UID/gnupg/S.gpg-agent.ssh"
+ # '';
# Without this, the gpg-agent has no way to ask the user for a password
# when invoked from ssh.