summaryrefslogtreecommitdiff
path: root/config/yubikey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/yubikey.nix')
-rw-r--r--config/yubikey.nix37
1 files changed, 1 insertions, 36 deletions
diff --git a/config/yubikey.nix b/config/yubikey.nix
index 5ff9e79..3029d90 100644
--- a/config/yubikey.nix
+++ b/config/yubikey.nix
@@ -12,12 +12,11 @@ let
];
in
{
- services.pcscd.enable = lib.mkForce false;
+ services.pcscd.enable = true;
services.udev.packages = with pkgs; [
libu2f-host
yubikey-personalization
];
- systemd.services.pcscd.after = ["multi-user.target"];
programs.gnupg.agent = {
enable = true;
@@ -26,41 +25,7 @@ in
# Use GPG agent instead.
programs.ssh.startAgent = lib.mkDefault false;
- # systemd.user.services.gpg-agent = {
- # path = [ pkgs.gnupg ];
- # description = "SSH Agent";
- # wantedBy = [ "default.target" ];
- # serviceConfig = {
- # ExecStartPre = ''
- # ${pkgs.gnupg}/bin/gpgconf --create-socketdir
- # ${pkgs.coreutils}/bin/rm -f %t/gnupg/S.gpg-agent.ssh
- # '';
- # ExecStart =
- # "${pkgs.gnupg}/bin/gpg-agent --enable-ssh-support --daemon";
- # Type = "forking";
- # Restart = "on-failure";
- # };
- # };
-
environment = {
systemPackages = yubikey-pkgs;
-
- # shellInit = ''
- # export GPG_TTY="$(tty)"
- # gpg-connect-agent /bye
- # export SSH_AUTH_SOCK="/run/user/$UID/gnupg/S.gpg-agent.ssh"
- # '';
-
- # Without this, the gpg-agent has no way to ask the user for a password
- # when invoked from ssh.
- # See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851440
- # extraInit = ''
- # gpg-connect-agent updatestartuptty /bye
- # '';
-
- # variables = {
- # SSH_AUTH_SOCK =
- # ''''${XDG_RUNTIME_DIR:-"/run/user/\$(id -u)"}/gnupg/S.gpg-agent.ssh'';
- # };
};
}