summaryrefslogtreecommitdiff
path: root/config/yubikey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/yubikey.nix')
-rw-r--r--config/yubikey.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/config/yubikey.nix b/config/yubikey.nix
index 3029d90..d10bb57 100644
--- a/config/yubikey.nix
+++ b/config/yubikey.nix
@@ -17,6 +17,7 @@ in
libu2f-host
yubikey-personalization
];
+ services.gnome3.gnome-keyring.enable = lib.mkForce false;
programs.gnupg.agent = {
enable = true;
@@ -28,4 +29,23 @@ in
environment = {
systemPackages = yubikey-pkgs;
};
+
+ security.sudo.extraRules = [
+ {
+ groups = [ "wheel" ];
+ commands = [ { command = "${pkgs.systemd}/bin/systemctl restart pcscd"; options = [ "NOPASSWD" ]; } ];
+ }
+ ];
+
+ systemd.user.services.restart-pcscd = {
+ description = "Redshift colour temperature adjuster";
+ wantedBy = [ "graphical-session.target" ];
+ partOf = [ "graphical-session.target" ];
+ serviceConfig = {
+ ExecStart = ''
+ sudo systemctl restart pcscd
+ '';
+ Type = "oneshot";
+ };
+ };
}