summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 4d5f5f1..9dfe528 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -30,10 +30,16 @@
root = "/storage/srv/orbekk.com";
};
"kj.orbekk.com" = template // {
- root = "${pkgs.www-orbekk}";
+ root = "/home/orbekk/www-public";
locations."/" = {
extraConfig = ''
try_files $uri @storage;
+ # kill cache
+ add_header Last-Modified $date_gmt;
+ add_header Cache-Control 'no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0';
+ if_modified_since off;
+ expires off;
+ etag off;
'';
};
locations."@storage" = {