summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 72613a6..bb40c12 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -1,5 +1,7 @@
{ config, lib, pkgs, ... }:
{
+ imports = [ ./orbekk-pkgs.nix ];
+
networking.firewall.allowedTCPPorts = [ 80 443 ];
services.nginx = {
enable = true;
@@ -23,6 +25,9 @@
"kj.orbekk.com" = {
enableACME = true;
forceSSL = true;
+ locations."/beta" = {
+ root = "${pkgs.www-orbekk}"
+ };
locations."/".proxyPass = "http://10.0.20.11:8011";
locations."/hledger" = {
extraConfig = ''return 302 /hledger/;'';