summaryrefslogtreecommitdiff
path: root/config/thinkpad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/thinkpad.nix')
-rw-r--r--config/thinkpad.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/config/thinkpad.nix b/config/thinkpad.nix
new file mode 100644
index 0000000..ff832b1
--- /dev/null
+++ b/config/thinkpad.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+{
+ services = {
+ tlp = {
+ enable = true;
+ extraConfig = ''
+ # Needed for either SSD or btrfs.
+ SATA_LINKPWR_ON_BAT=max_performance
+ '';
+ };
+ xserver.xkbModel = "thinkpad60";
+ };
+
+ boot = {
+ kernelModules = [ "tp_smapi" "thinkpad_acpi" "fbcon" "i915" "acpi_call" ];
+ extraModulePackages = with config.boot.kernelPackages [ tp_smapi acpi_call ];
+ }
+
+ systemd.services = {
+ battery_threshold = {
+ description = "Set battery charging thresholds.";
+ path = [ pkgs.tpacpi-bat ];
+ after = [ "basic.target" ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ tpacpi-bat -s ST 1 39
+ tpacpi-bat -s ST 2 39
+ tpacpi-bat -s SP 1 80
+ tpacpi-bat -s SP 2 80
+ '';
+ };
+ };
+}