summaryrefslogtreecommitdiff
path: root/config/thinkpad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/thinkpad.nix')
-rw-r--r--config/thinkpad.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/config/thinkpad.nix b/config/thinkpad.nix
deleted file mode 100644
index 5bd1707..0000000
--- a/config/thinkpad.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, lib, pkgs, ... }:
-{
- services = {
- tlp = {
- enable = true;
- settings = {
- "SATA_LINKPWR_ON_BAT" = "max_performance";
- };
- };
- xserver.xkbModel = "thinkpad60";
- };
-
- boot = {
- kernelModules = [ "tp_smapi" "thinkpad_acpi" "fbcon" "i915" "acpi_call" ];
- extraModulePackages = with config.boot.kernelPackages; [ tp_smapi acpi_call ];
- };
-
- systemd.services = {
- battery_threshold = {
- description = "Set battery charging thresholds.";
- path = [ pkgs.tpacpi-bat ];
- after = [ "basic.target" ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- tpacpi-bat -s ST 1 39
- tpacpi-bat -s ST 2 39
- tpacpi-bat -s SP 1 80
- tpacpi-bat -s SP 2 80
- '';
- };
- };
-}