summaryrefslogtreecommitdiff
path: root/config/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/router.nix')
-rw-r--r--config/router.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/config/router.nix b/config/router.nix
index 3003c0e..83a2d64 100644
--- a/config/router.nix
+++ b/config/router.nix
@@ -2,8 +2,11 @@
let
wan-dev = "eno1";
lan-dev = "eno2";
+ mullvadPort = config.orbekk.mullvad.listenPort;
in
{
+ orbekk.mullvad.enable = true;
+
networking.networkmanager.enable = lib.mkForce false;
networking.nameservers = [ "8.8.8.8" ];
@@ -61,6 +64,7 @@ in
proto tcp dport ssh ACCEPT;
proto (tcp udp) dport domain ACCEPT;
proto tcp dport (http https) ACCEPT;
+ proto udp dport ${mullvadPort} ACCEPT;
}
interface $DEV_LAN @subchain "lan_services" {