summaryrefslogtreecommitdiff
path: root/config/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/router.nix')
-rw-r--r--config/router.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/config/router.nix b/config/router.nix
index db02093..df1f931 100644
--- a/config/router.nix
+++ b/config/router.nix
@@ -2,13 +2,13 @@
let
wan-dev = "bond0.10";
lan-dev = "bond0";
- wireguardPort = config.orbekk.wireguard.listenPort;
+ wireguardPorts =
+ [ config.orbekk.mullvad.listenPort config.orbekk.nycmesh.listenPort ];
mullvadMark = 30;
nycmeshMark = 32;
in {
- orbekk.wireguard.enable = true;
- orbekk.wireguard.enableMullvad = true;
- orbekk.wireguard.enableNycmesh = true;
+ orbekk.mullvad.enable = true;
+ orbekk.nycmesh.enable = true;
services.tftpd.enable = true;
services.openntpd.enable = true;
@@ -91,7 +91,7 @@ in {
proto tcp dport ssh ACCEPT;
proto (tcp udp) dport domain ACCEPT;
proto tcp dport (http https) ACCEPT;
- proto udp dport ${toString wireguardPort} ACCEPT;
+ proto udp dport (${lib.concatStringsSep " " (map toString wireguardPorts)}) ACCEPT;
}
interface ($DEV_LAN $DEV_ADMIN) @subchain "lan_services" {