summaryrefslogtreecommitdiff
path: root/config/pxe.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/pxe.nix')
-rw-r--r--config/pxe.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/config/pxe.nix b/config/pxe.nix
new file mode 100644
index 0000000..fcf839e
--- /dev/null
+++ b/config/pxe.nix
@@ -0,0 +1,12 @@
+{ config, lib, pkgs, ... }:
+{
+ services.dnsmasq = {
+ extraConfig = ''
+ enable-tftp
+ tftp-root=${pkgs.ipxe}
+ dhcp-userclass=set:ipxe,iPXE
+ dhcp-boot=tag:!ipxe,undionly.kpxe
+ dhcp-boot=http://boot.ipxe.org/demo/boot.php
+ '';
+ };
+}