summaryrefslogtreecommitdiff
path: root/config/pjournal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/pjournal.nix')
-rw-r--r--config/pjournal.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/config/pjournal.nix b/config/pjournal.nix
index b0ac9da..840e72a 100644
--- a/config/pjournal.nix
+++ b/config/pjournal.nix
@@ -20,7 +20,7 @@ in
services.postgresql = {
enable = true;
- ensureDatabases = ["pjournal" "pjournal_test"];
+ ensureDatabases = ["pjournal"];
ensureUsers = [
{
name = "pjournal";
@@ -28,31 +28,25 @@ in
"DATABASE pjournal" = "ALL PRIVILEGES";
};
}
- {
- name = "pjournal_test";
- ensurePermissions = {
- "DATABASE pjournal_test" = "ALL PRIVILEGES";
- };
- }
];
};
- systemd.services.pjournal-test = {
- description = "pjournal test instance";
+ systemd.services.pjournal = {
+ description = "pjournal instance";
after = [ "multi-user.target" "postgresql.service" ];
wantedBy = ["multi-user.target"];
environment = {
RUST_BACKTRACE = "1";
};
+ script = ''
+ # This will fail the first time. Run pjournal init to initialize
+ # the database.
+ ${cfg.package}/bin/pjournal \
+ --database_url postgres://pjournal@/pjournal \
+ --port 8080
+ '';
serviceConfig = {
- ExecStart = ''
- # This will fail the first time. Run pjournal init to initialize
- # the database.
- ${cfg.package}/bin/pjournal \
- --database_url postgres://pjournal_test@/pjournal_test \
- --port 8080
- '';
- User = "pjournal_test";
+ User = "pjournal";
};
};