summaryrefslogtreecommitdiff
path: root/config/pjournal.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-26 20:15:47 -0500
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-26 20:16:07 -0500
commit954d0edebd7a3e5cebf93f5053a4b8f18c77feae (patch)
tree51552907ca462045941e2a8a05591ea9fa1d3a11 /config/pjournal.nix
parentd82cef533e530f519358ae163d747df1829e3083 (diff)
Update pjournal to a working service
Diffstat (limited to 'config/pjournal.nix')
-rw-r--r--config/pjournal.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/config/pjournal.nix b/config/pjournal.nix
index b0ac9da..840e72a 100644
--- a/config/pjournal.nix
+++ b/config/pjournal.nix
@@ -20,7 +20,7 @@ in
services.postgresql = {
enable = true;
- ensureDatabases = ["pjournal" "pjournal_test"];
+ ensureDatabases = ["pjournal"];
ensureUsers = [
{
name = "pjournal";
@@ -28,31 +28,25 @@ in
"DATABASE pjournal" = "ALL PRIVILEGES";
};
}
- {
- name = "pjournal_test";
- ensurePermissions = {
- "DATABASE pjournal_test" = "ALL PRIVILEGES";
- };
- }
];
};
- systemd.services.pjournal-test = {
- description = "pjournal test instance";
+ systemd.services.pjournal = {
+ description = "pjournal instance";
after = [ "multi-user.target" "postgresql.service" ];
wantedBy = ["multi-user.target"];
environment = {
RUST_BACKTRACE = "1";
};
+ script = ''
+ # This will fail the first time. Run pjournal init to initialize
+ # the database.
+ ${cfg.package}/bin/pjournal \
+ --database_url postgres://pjournal@/pjournal \
+ --port 8080
+ '';
serviceConfig = {
- ExecStart = ''
- # This will fail the first time. Run pjournal init to initialize
- # the database.
- ${cfg.package}/bin/pjournal \
- --database_url postgres://pjournal_test@/pjournal_test \
- --port 8080
- '';
- User = "pjournal_test";
+ User = "pjournal";
};
};