summaryrefslogtreecommitdiff
path: root/config/mpd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/mpd.nix')
-rw-r--r--config/mpd.nix32
1 files changed, 16 insertions, 16 deletions
diff --git a/config/mpd.nix b/config/mpd.nix
index 7815f61..a9dcee0 100644
--- a/config/mpd.nix
+++ b/config/mpd.nix
@@ -1,8 +1,8 @@
{ config, lib, pkgs, ... }:
- let mpdport = (import ../data/aliases.nix).services.mpd.port;
- mpdwebport = (import ../data/aliases.nix).services.mpdweb.port;
- in
-{
+let
+ mpdport = (import ../data/aliases.nix).services.mpd.port;
+ mpdwebport = (import ../data/aliases.nix).services.mpdweb.port;
+in {
networking.firewall.allowedTCPPorts = [ mpdport mpdwebport ];
services.ympd = {
@@ -14,18 +14,18 @@
enable = true;
musicDirectory = "/storage/music";
extraConfig = ''
- audio_output {
- type "httpd"
- name "KJ mpd stream"
- encoder "lame"
- port "${toString mpdport}"
- quality "0" # do not define if bitrate is defined
- #bitrate "128" # do not define if quality is defined
- format "44100:16:1"
- always_on "yes" # prevent MPD from disconnecting all listeners when playback is stopped.
- tags "yes" # httpd supports sending tags to listening streams.
- audio_buffer_size "8192"
- }
+ audio_output {
+ type "httpd"
+ name "KJ mpd stream"
+ encoder "lame"
+ port "${toString mpdport}"
+ quality "0" # do not define if bitrate is defined
+ #bitrate "128" # do not define if quality is defined
+ format "44100:16:1"
+ always_on "yes" # prevent MPD from disconnecting all listeners when playback is stopped.
+ tags "yes" # httpd supports sending tags to listening streams.
+ audio_buffer_size "8192"
+ }
'';
};
}