summaryrefslogtreecommitdiff
path: root/config/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/gaming.nix')
-rw-r--r--config/gaming.nix75
1 files changed, 0 insertions, 75 deletions
diff --git a/config/gaming.nix b/config/gaming.nix
deleted file mode 100644
index 2cc57dc..0000000
--- a/config/gaming.nix
+++ /dev/null
@@ -1,75 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
- pkgs_unstable = pkgs.my-extras.nixpkgs-unstable.legacyPackages.${pkgs.system};
- my_steam = self: super: {
- steam = super.steam.override {
- # steam = pkgs_unstable.steam.override {
- # nativeOnly = true;
- withJava = true;
- extraPkgs = p: with pkgs;
- let xorgdeps = with xorg; [
- libX11 libXrender libXrandr libxcb libXmu libpthreadstubs libXext libXdmcp
- libXxf86vm libXinerama libSM libXv libXaw libXi libXcursor libXcomposite
- ];
- in [
- samba
- tdb
- glib-networking
- libxkbcommon
- fluidsynth hidapi mesa libdrm
- perl which p7zip gnused gnugrep psmisc opencl-headers
- cups lcms2 mpg123 cairo unixODBC samba4 sane-backends openldap ocl-icd utillinux
- fribidi
- libsndfile libtheora libogg libvorbis libopus libGLU libpcap libpulseaudio
- libao libusb libevdev udev libgcrypt libxml2 libusb libpng libmpeg2 libv4l
- libjpeg libxkbcommon libass libcdio libsamplerate libzip libmad libaio
- libcap libtiff libva libgphoto2 libxslt libsndfile giflib zlib glib
- alsaLib zziplib bash dbus keyutils zip cabextract freetype unzip coreutils
- readline gcc SDL SDL2 curl graphite2 gtk2 gtk3 udev ncurses wayland libglvnd
- vulkan-loader xdg_utils sqlite gnutls libbsd
- libnghttp2
- openssl
- openldap
- xorg.xrandr
- xorg.xinput
- gnome3.gtk
- zlib
- dbus
- freetype
- glib
- atk
- cairo
- gdk_pixbuf
- pango
- fontconfig
- xorg.libxcb
- libkrb5
- nss
- qt4
- pkgs_unstable.qt514.full
- libjack2 jack2 jack2Full jack_capture
- libidn2
- rtmpdump
- libpsl
- ] ++ xorgdeps;
- };
- };
-in
-{
- nixpkgs.overlays = [ my_steam ];
- # nixpkgs.config.allowBroken = true;
- nixpkgs.config.allowUnfree = true;
- # nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
- # "steam"
- # ];
-
- programs.steam.enable = true;
- hardware.opengl.extraPackages32 = with pkgs.pkgsi686Linux; [ libva ];
-
- environment.systemPackages = with pkgs; [
- wineWowPackages.staging
- steam
- steam.run
- obs-studio
- ];
-}