summaryrefslogtreecommitdiff
path: root/config/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/desktop.nix')
-rw-r--r--config/desktop.nix102
1 files changed, 0 insertions, 102 deletions
diff --git a/config/desktop.nix b/config/desktop.nix
deleted file mode 100644
index 4380537..0000000
--- a/config/desktop.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-{ config, lib, pkgs, ... }:
-{
- imports = [ ./common.nix ./users.nix ];
-
- location.latitude = 40.0;
- location.longitude = -74.0;
-
- sound.enable = true;
-
- hardware = {
- opengl = {
- enable = true;
- driSupport32Bit = true;
- extraPackages32 = with pkgs.pkgsi686Linux; [ libva ];
- };
-
- bluetooth.enable = true;
- pulseaudio = {
- enable = true;
- support32Bit = true;
- package = pkgs.pulseaudioFull;
- zeroconf.discovery.enable = true;
- zeroconf.publish.enable = true;
- tcp.enable = true;
- tcp.anonymousClients.allowAll = true;
- };
- };
-
- fonts = {
- enableDefaultFonts = true;
- fonts = with pkgs; [ fira-code dejavu_fonts steamPackages.steam-fonts wqy_microhei ];
- fontconfig = {
- defaultFonts = {
- sansSerif = [ "Noto Sans" "WenQuanYi Micro Hei" ];
- serif = [ "Noto Serif" "WenQuanYi Micro Hei-14" ];
- emoji = [ "Noto Color Emoji" ];
- monospace = [ "DejaVu Sans Mono" "WenQuanYi Micro Hei Mono" ];
- };
- };
- };
-
- environment.systemPackages = with pkgs; [
- chromium
- dmenu
- emacs
- firefox
- haskellPackages.xmobar
- pavucontrol
- rxvt_unicode-with-plugins
- sshfsFuse
- trayer
- (conky.override { pulseSupport = true; })
- xbindkeys
- xorg.xbacklight
- xorg.xev
- xscreensaver
- xsel # used by urxvt clipboard
- xss-lock
- networkmanagerapplet
- imagemagick
- dzen2
- rofi
- autorandr
- ];
-
- i18n.inputMethod = {
- enabled = "fcitx";
- fcitx.engines = with pkgs.fcitx-engines; [cloudpinyin];
- };
-
- services = {
- avahi.enable = true;
-
- xserver = {
- enable = true;
- layout = "us";
- # xkbVariant = "dvorak";
- xkbOptions = "caps:ctrl_modifier";
-
- # desktopManager.plasma5 = {
- # enable = true;
- # };
-
- windowManager.xmonad = {
- enable = true;
- enableContribAndExtras = true;
- extraPackages = hpkgs: [ hpkgs.xmobar hpkgs.split ];
- };
-
- displayManager.lightdm = {
- enable = true;
- };
-
- libinput.enable = true;
- };
-
- redshift = {
- enable = true;
- extraOptions = ["-r"];
- };
- };
-}