summaryrefslogtreecommitdiff
path: root/config/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/desktop.nix')
-rw-r--r--config/desktop.nix43
1 files changed, 17 insertions, 26 deletions
diff --git a/config/desktop.nix b/config/desktop.nix
index 6b26b07..58fbbdd 100644
--- a/config/desktop.nix
+++ b/config/desktop.nix
@@ -5,42 +5,30 @@
location.latitude = 40.0;
location.longitude = -74.0;
+ sound.enable = true;
+
hardware = {
opengl = {
enable = true;
driSupport32Bit = true;
+ extraPackages32 = with pkgs.pkgsi686Linux; [ libva ];
};
bluetooth.enable = true;
pulseaudio = {
enable = true;
+ support32Bit = true;
package = pkgs.pulseaudioFull;
zeroconf.discovery.enable = true;
zeroconf.publish.enable = true;
+ tcp.enable = true;
+ tcp.anonymousClients.allowAll = true;
};
};
- console.earlySetup = true;
- console.keyMap = "dvorak";
-
- boot = {
-
- loader = {
- systemd-boot.enable = true;
- # systemd-boot.memtest86.enable = true;
- timeout = 0;
- efi.canTouchEfiVariables = true;
- };
- };
-
- networking = {
- networkmanager.enable = lib.mkDefault true;
- firewall.enable = lib.mkDefault true;
- };
-
fonts = {
enableDefaultFonts = true;
- fonts = [ pkgs.fira-code pkgs.dejavu_fonts pkgs.steamPackages.steam-fonts ];
+ fonts = with pkgs; [ fira-code dejavu_fonts steamPackages.steam-fonts wqy_microhei ];
};
environment.systemPackages = with pkgs; [
@@ -61,6 +49,11 @@
xss-lock
];
+ i18n.inputMethod = {
+ enabled = "fcitx";
+ fcitx.engines = with pkgs.fcitx-engines; [cloudpinyin];
+ };
+
services = {
avahi.enable = true;
@@ -70,10 +63,11 @@
enable = true;
layout = "us";
# xkbVariant = "dvorak";
+ xkbOptions = "caps:ctrl_modifier";
- desktopManager.mate = {
- enable = true;
- };
+ # desktopManager.plasma5 = {
+ # enable = true;
+ # };
windowManager.xmonad = {
enable = true;
@@ -85,10 +79,7 @@
enable = true;
};
- synaptics = {
- enable = true;
- twoFingerScroll = true;
- };
+ libinput.enable = true;
};
redshift = {