summaryrefslogtreecommitdiff
path: root/config/ap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/ap.nix')
-rw-r--r--config/ap.nix25
1 files changed, 22 insertions, 3 deletions
diff --git a/config/ap.nix b/config/ap.nix
index 18c0c6e..4f3c634 100644
--- a/config/ap.nix
+++ b/config/ap.nix
@@ -6,6 +6,15 @@ in
{
networking.networkmanager.enable = lib.mkForce false;
+ # networking.vlans.lan = {
+ # id = 110;
+ # interface = wan-dev;
+ # };
+ # networking.vlans.wan = {
+ # id = 100;
+ # interface = wan-dev;
+ # };
+
networking.firewall = {
enable = lib.mkForce false;
allowedTCPPorts = lib.mkForce [ ];
@@ -97,6 +106,8 @@ in
};
boot.kernel.sysctl = {
+ # Something wrong with Spectrum ipv6 :(
+ "net.ipv6.conf.all.disable_ipv6" = true;
"net.ipv4.conf.all.forwarding" = true;
"net.ipv4.conf.default.forwarding" = true;
"net.ipv6.conf.all.forwarding" = true;
@@ -154,9 +165,17 @@ in
# internalIPs = [ "10.0.0.0/24" ];
};
- networking.interfaces.${wan-dev} = {
- macAddress = "3c:97:0e:19:7e:5c";
- };
+ # Error matching on link that was already renamed.
+ # systemd.network.links."40-enp37s0".matchConfig = {
+ # # OriginalName = lib.mkForce null;
+ # # MACAddress = "00:d8:61:c2:c6:6c";
+ # };
+ # systemd.services.dhcpcd.preStart = lib.mkAfter ''
+ # ${pkgs.iproute}/bin/ip link set dev ${wan-dev} address ${config.networking.interfaces.${wan-dev}.macAddress};
+ # '';
+ # networking.interfaces.${wan-dev} = {
+ # macAddress = "3c:97:0e:19:7e:5c";
+ # };
networking.interfaces."${lan-dev}" = {
ipv4.addresses = [ {