summaryrefslogtreecommitdiff
path: root/modules/vpn.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2022-08-28 18:22:08 -0400
committerKjetil Orbekk <kj@orbekk.com>2022-08-28 18:22:08 -0400
commitb1336c73169638bb9a5343dd89c94069adbf16b0 (patch)
treee0561b73d1a28f1b65dcc9050262bef3de0ae5a4 /modules/vpn.nix
parent76517769bcaf1f1a94b1842633cfb602e9322202 (diff)
Add extra ip to steamdeck
Diffstat (limited to 'modules/vpn.nix')
-rw-r--r--modules/vpn.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/vpn.nix b/modules/vpn.nix
index 63442ff..5f8d932 100644
--- a/modules/vpn.nix
+++ b/modules/vpn.nix
@@ -22,7 +22,12 @@ let
};
firelink = mkConfig "firelink" "2001";
pincer = mkConfig "pincer" "2002";
- steamdeck = mkConfig "steamdeck" "2003";
+ steamdeck = mkConfig "steamdeck" "2003" // {
+ ips = [
+ "${vpn-prefix}::2003/128"
+ "${vpn-prefix}::2004/128"
+ ];
+ };
};
mkPeer = hostConfig: {