summaryrefslogtreecommitdiff
path: root/machines/x220-aji.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-19 09:11:04 -0400
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-19 09:12:08 -0400
commitf2150e72c0c5b371a769acf3acacb13abd713cbc (patch)
tree1133eb4ea90796f6d17882a0f9a242903e0e92b1 /machines/x220-aji.nix
parentc164c8ec03f24e9b7a8081b5e51db468fc546504 (diff)
aji: Add configuration.
Diffstat (limited to 'machines/x220-aji.nix')
-rw-r--r--machines/x220-aji.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/machines/x220-aji.nix b/machines/x220-aji.nix
new file mode 100644
index 0000000..7cec5a1
--- /dev/null
+++ b/machines/x220-aji.nix
@@ -0,0 +1,50 @@
+{ config, lib, pkgs, ... }:
+{
+ imports = [
+ ../config/desktop.nix
+ ../config/thinkpad.nix
+ ];
+
+ networking = {
+ hostName = "aji";
+ };
+
+ boot = {
+ initrd.luks.devices = [
+ {
+ device = "/dev/sda2";
+ name = "cryptroot";
+ allowDiscards = true;
+ }
+ ];
+
+ extraModulePackages = [ config.boot.kernelPackages.tp_smapi ];
+
+ extraModprobeConfig = ''
+ option i915 enable_rc6=1
+ '';
+ };
+
+ fileSystems = {
+ "/boot" = {
+ mountPoint = "/boot";
+ device = "/dev/disk/by-uuid/829B-F56C";
+ fsType = "vfat";
+ };
+ "/" = {
+ mountPoint = "/";
+ device = "/dev/mapper/cryptvg-root";
+ fsType = "btrfs";
+ options = ["subvol=aji-root" "discard" "compress=lzo"];
+ };
+ "/btrfs" = {
+ mountPoint = "/btrfs";
+ device = "/dev/mapper/cryptvg-root";
+ fsType = "btrfs";
+ options = ["discard" "compress=lzo"];
+ };
+ };
+ swapDevices =
+ [ { device = "/dev/mapper/cryptvg-swap"; }
+ ];
+}