summaryrefslogtreecommitdiff
path: root/machines/x1-pincer.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-13 10:41:48 -0400
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-13 10:41:48 -0400
commit9b0220f68fa95b8f2b1d6d3ee3466798a134f57e (patch)
treedfc7c89341976113345e42e013bd3dad28359b5a /machines/x1-pincer.nix
parent5ffdf367cdf06666e45973d6aeb3862289b27334 (diff)
Add refactored nixos configuration for laptop pincer.
Diffstat (limited to 'machines/x1-pincer.nix')
-rw-r--r--machines/x1-pincer.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/machines/x1-pincer.nix b/machines/x1-pincer.nix
new file mode 100644
index 0000000..940cd91
--- /dev/null
+++ b/machines/x1-pincer.nix
@@ -0,0 +1,45 @@
+{ config, lib, pkgs, ... }:
+{
+ imports = [
+ ../config/desktop.nix
+ ../config/thinkpad.nix
+ ];
+
+ networking = {
+ hostName = "pincer";
+ };
+
+ boot = {
+ initrd.luks.devices = [
+ {
+ device = "/dev/sda6";
+ name = "cryptroot";
+ allowDiscards = true;
+ };
+ ];
+
+ extraModprobeConfig = ''
+ option iwlwifi swcrypto=1
+ '';
+ };
+
+ fileSystems = {
+ "/boot" = {
+ mountPoint = "/boot";
+ device = "/dev/sda1";
+ fsType = "vfat";
+ };
+ "/" = {
+ mountPoint = "/";
+ device = "/dev/mapper/cryptroot";
+ fsType = "btrfs";
+ options = ["subvol=active/nixos-root" "discard" "compress=lzo"];
+ };
+ "/btrfs" = {
+ mountPoint = "/btrfs";
+ device = "/dev/mapper/cryptroot";
+ fsType = "btrfs";
+ options = ["discard" "compress=lzo"];
+ };
+ };
+}