summaryrefslogtreecommitdiff
path: root/machines/dragon.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2022-10-22 22:05:54 -0400
committerKjetil Orbekk <kj@orbekk.com>2022-10-22 22:06:59 -0400
commitbca72f1d780f9abd7959ce81e153c11913f218f3 (patch)
tree87a36a69b0a07a1ac2ab4a34548e5a7846255767 /machines/dragon.nix
parent0a7e53a85abacb298f410b4ff8ca1b7ea035924c (diff)
Enable samba share
Diffstat (limited to 'machines/dragon.nix')
-rw-r--r--machines/dragon.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/machines/dragon.nix b/machines/dragon.nix
index d7dc80e..740d308 100644
--- a/machines/dragon.nix
+++ b/machines/dragon.nix
@@ -28,6 +28,26 @@ in {
orbekk.hledger-web.journalFile =
"/var/lib/hledger-web/hledger/anniekj.journal";
+ services.samba = {
+ enable = true;
+ extraConfig = ''
+ guest account = nobody
+ map to guest = bad user
+ '';
+ shares = {
+ public = {
+ path = "/storage/upload";
+ browseable = "yes";
+ "read only" = "no";
+ "guest ok" = "yes";
+ "create mask" = "0644";
+ "directory mask" = "0755";
+ "force user" = "readonly";
+ "force group" = "readonly";
+ };
+ };
+ };
+
# virtualisation.lxd.enable = true;
boot = {