summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
authorKJ Ørbekk <kj@orbekk.com>2017-09-08 09:14:45 -0400
committerKJ Ørbekk <kj@orbekk.com>2017-09-08 09:14:45 -0400
commitfb7bf971568b596cc09a15f7f5e23eb67590de5a (patch)
tree8832b5fc3d4d449a23bfbd3e8bb53a0a7def5766 /config/web-server.nix
parent417f24fb3a126d8f37394b774bbec83d465511ce (diff)
Add ssl endpoint for kufieta.net
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix39
1 files changed, 14 insertions, 25 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 6add97c..179d9d3 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -11,29 +11,21 @@
# large downloads.
proxy_buffering off;
'';
- virtualHosts = {
- "orbekk.no" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ virtualHosts = let template = {
+ enableACME = true;
+ forceSSL = true;
+ };
+ in {
+ "orbekk.no" = template // {
root = "/storage/srv/orbekk.com";
};
- "orbekk.com" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ "orbekk.com" = template // {
root = "/storage/srv/orbekk.com";
};
- "shape.orbekk.com" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ "shape.orbekk.com" = template // {
root = "/storage/srv/orbekk.com";
};
- "kj.orbekk.com" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ "kj.orbekk.com" = template // {
root = "${pkgs.www-orbekk}";
locations."/" = {
extraConfig = ''
@@ -63,20 +55,17 @@
proxyPass = "http://10.0.20.15:11102";
};
};
- "git.orbekk.com" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ "git.orbekk.com" = template // {
locations."/".proxyPass = "http://10.0.20.15:11103";
};
- "hydra.orbekk.com" = {
- enableACME = true;
- forceSSL = true;
- addSSL = true;
+ "hydra.orbekk.com" = template // {
locations."/" = {
proxyPass = "http://10.0.20.15:11101";
};
};
+ "kufieta.net" = template // {
+ locations."/".proxyPass = "http://10.0.20.13";
+ };
};
};
}