summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
authorKjetil Ørbekk <kj@orbekk.com>2018-03-28 14:57:20 -0400
committerKjetil Ørbekk <kj@orbekk.com>2018-03-28 14:57:20 -0400
commit6d4b55a57fb7fc479d9b554f5a7e9c9f7cb0ec36 (patch)
tree15ea952bec917ec89899d2ffce5284e976390abf /config/web-server.nix
parent73a63278c192be1d1bc02d531a250d7e32671f15 (diff)
add mpd service
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 2e0d56f..4d5f5f1 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -1,4 +1,7 @@
{ config, lib, pkgs, ... }:
+ let mpd_loc = (import ../data/aliases.nix).services.mpd;
+ mpdweb_loc = (import ../data/aliases.nix).services.mpdweb;
+ in
{
imports = [ ./orbekk-pkgs.nix ];
@@ -47,6 +50,9 @@
alias = "/var/www/munin/";
extraConfig = "autoindex on;";
};
+ locations."/mpd" = {
+ proxyPass = "http://${mpd_loc.address}:${toString mpd_loc.port}/";
+ };
#locations."/systemd" = {
# proxyPass = "http://10.0.20.15:11105/";
#};
@@ -64,6 +70,11 @@
proxyPass = "http://10.0.20.15:11102";
};
};
+ "ympd.orbekk.com" = template // {
+ locations."/" = {
+ proxyPass = "http://${mpdweb_loc.address}:${toString mpdweb_loc.port}/";
+ };
+ };
"git.orbekk.com" = template // {
locations."/".proxyPass = "http://10.0.20.2:11103";
};