summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-26 20:16:30 -0500
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2020-02-26 20:27:09 -0500
commit457585940971ce34a8e46b330b3bb729cc1af3f8 (patch)
treee571ac51ddf1a7569e6b24af497500983a97976a /config/web-server.nix
parent954d0edebd7a3e5cebf93f5053a4b8f18c77feae (diff)
Run pjournal on dragon
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 4ef070b..77a508a 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -1,6 +1,7 @@
{ config, lib, pkgs, ... }:
let mpd_loc = (import ../data/aliases.nix).services.mpd;
mpdweb_loc = (import ../data/aliases.nix).services.mpdweb;
+ pjournal_loc = (import ../data/aliases.nix).services.pjournal;
in
{
imports = [ ./orbekk-pkgs.nix ];
@@ -34,7 +35,7 @@
locations."/" = {
extraConfig = ''
try_files $uri @storage;
- # kill cache
+ # kill cache
add_header Last-Modified $date_gmt;
add_header Cache-Control 'no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0';
if_modified_since off;
@@ -56,9 +57,9 @@
alias = "/var/www/munin/";
extraConfig = "autoindex on;";
};
- locations."/mpd" = {
- proxyPass = "http://${mpd_loc.address}:${toString mpd_loc.port}/";
- };
+ locations."/mpd" = {
+ proxyPass = "http://${mpd_loc.address}:${toString mpd_loc.port}/";
+ };
#locations."/systemd" = {
# proxyPass = "http://10.0.20.15:11105/";
#};
@@ -92,6 +93,9 @@
"kufieta.net" = template // {
locations."/".proxyPass = "http://10.0.20.13:8080";
};
+ "journal.orbekk.com" = template // {
+ locations."/".proxyPass = "http://${pjournal_loc.address}:${toString pjournal_loc.port}";
+ };
};
};
}