summaryrefslogtreecommitdiff
path: root/config/web-server.nix
diff options
context:
space:
mode:
authorKjetil Ørbekk <kj@orbekk.com>2020-02-26 21:53:23 -0500
committerKjetil Ørbekk <kj@orbekk.com>2020-02-26 21:53:23 -0500
commit36f1c9edf79d7d9e74135954a1280233cff5a681 (patch)
tree9953d73e8b9ebba66a65aff24d2a070d55213221 /config/web-server.nix
parenta3778e547e13c1e0b6b4d1d75a4c2cc700773982 (diff)
Upgrade dragon to NixOS 20.03
Diffstat (limited to 'config/web-server.nix')
-rw-r--r--config/web-server.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/config/web-server.nix b/config/web-server.nix
index 77a508a..bd2c35d 100644
--- a/config/web-server.nix
+++ b/config/web-server.nix
@@ -6,6 +6,9 @@
{
imports = [ ./orbekk-pkgs.nix ];
+ security.acme.acceptTerms = true;
+ security.acme.email = "kj@orbekk.com";
+
networking.firewall.allowedTCPPorts = [ 80 443 ];
services.nginx = {
enable = true;
@@ -49,17 +52,17 @@
autoindex on;
'';
};
- locations."/stats" = {
+ locations."/stats/" = {
alias = "/var/lib/stats/out/";
extraConfig = "autoindex on;";
};
- locations."/munin" = {
+ locations."/munin/" = {
alias = "/var/www/munin/";
extraConfig = "autoindex on;";
};
- locations."/mpd" = {
- proxyPass = "http://${mpd_loc.address}:${toString mpd_loc.port}/";
- };
+ locations."/mpd" = {
+ proxyPass = "http://${mpd_loc.address}:${toString mpd_loc.port}/";
+ };
#locations."/systemd" = {
# proxyPass = "http://10.0.20.15:11105/";
#};